Lan Adapter Install Driver Problem

  VistaDJ 09:06 13 May 14
Locked

Hi

Have a HP Pavilion DV6000 with Vista. Vista on boot tries to install Lan Adapter but can not find driver. In Device Mgr the Lan Adapter is just identified as Ethernet Controller. I have tried the HP driver I down loaded from there web site no joy. I downloaded the Intel ProWin32.exe latest, still no joy. However I can go to Device Mgr and install a Lan Driver via the Legacy option but the Device just shows the yellow exclamation mark. The interesting point is if I look at the Hardware Id of the system installed Ethernet Controller it shows:

PCI\VEN8086&DEV1000&SUBSYS30BB0004&REV00 PCI\VEN8086&DEV1000&SUBSYS_30BB0004 PCI\VEN8086&DEV1000&CC_020000 PCI\VEN8086&DEV1000&CC_0200

If I install the driver (this depends on the driver installed) via the Legacy option in Dev Mgr the Hardware Id shows:

pci\ven8086&dev10c5&subsys_10c58086

So obviously the Hardware Id is coming from the driver installed not the Hardware it's self.

Can anyone stear me in the right direction to fix this.

Thanks.

  Jollyjohn 12:40 14 May 14

Have you looked at this page?

click here is what came up when I searched for HP DV6000

I know it is a wireless driver but it will then allow a wireless connection and it may contain the drivers for the ethernet controller that shows in device manager.

It

  VistaDJ 14:01 14 May 14

Hi thank you for the reply. I have been to this web page before. The WiFi Adapter actually works fine.

It is just the Lan Adapter that will not work. In my opinion there seems to be something screwed in the Registry between where the Adapter is recognised on the PCI bus and the Adapter driver.

  onthelimit1 15:43 14 May 14

As the WiFi works, download the free version of Slimdrivers, I suggest from Major Geeks Let it run - it will find loads of drivers that it thinks need updating - ignore those. It should point to the correct LAN driver from the manufacturers site.

  Jollyjohn 16:07 14 May 14

You could try a reboot, disable LAN adapter in the BIOS, allow windows to start, check there is no trace of LAN adapter, reboot, re enable and when New Hardware Wizard starts, allow it to connect to the internet, and see if it finds the correct driver.

This thread is now locked and can not be replied to.

The Legend of Zelda Breath of the Wild review: Five hours with Zelda on the Nintendo Switch

1995-2015: How technology has changed the world in 20 years

How the painting-like animated sequences in A Monster Calls were created by Glassworks Barcelona

The 22 best Safari extensions | Best Safari plugins: Improve Apple's Safari web browser with these…