Lacie External HD vanished without trace...

  soulboy 15:41 PM 23 Sep 11
Locked
Answered

Hello,

My Lacie 500GB external drive has vanished, again! This happened before, but as the drive still showed up in windows I managed to enable it somehow (I can't remember how!) The drive has now disappeared again, it still lights up and disk 'whirrs' inside, but the thing is completely 'invisible' to Windows(XP SP3)this time. Have glanced over a couple of threads in PC Advisor, maybe my powert supply is faulty? Help would be much appreciated...

  Fruit Bat /\0/\ 17:34 PM 23 Sep 11

HAve a look in disk management can you see it there?

Right click My computer - Manage - Storage - Disk Management

  soulboy 17:39 PM 23 Sep 11

No. Last time I couldn't gain access to the drive I could see it there, but this time it's completely invisible. I have recently re-installed windows.

  Graphicool1 18:27 PM 23 Sep 11
Answer

soulboy

Have you tried plugging it into a different USB port? This has sometimes worked for me in the past.

  Fruit Bat /\0/\ 18:27 PM 23 Sep 11

try plugging into a different USB port

also check in device manager that you have an enhanced driver under USB heading

  soulboy 19:27 PM 23 Sep 11

Thanks fruitbat, you are a star! It was somethi8ng really obvious that I would not have checked without your advice... the boloody thing wasn't plugged in, I must have knocked it out whilst re-routing some hi-fi stuff. Thanks mate! I'm so gormless!

Peace

SB

Advertisement

This thread is now locked and can not be replied to.

Sony Xperia Z5 review: Hands-on with the phone which the Z3+ should have been

1995-2015: How technology has changed the world in 20 years

Get your photos turned into illos by some of the world’s best artists

What to expect at the September Apple event: Apple announces 9 September event, sends out invites