Lacie External HD vanished without trace...

  soulboy 15:41 PM 23 Sep 11


My Lacie 500GB external drive has vanished, again! This happened before, but as the drive still showed up in windows I managed to enable it somehow (I can't remember how!) The drive has now disappeared again, it still lights up and disk 'whirrs' inside, but the thing is completely 'invisible' to Windows(XP SP3)this time. Have glanced over a couple of threads in PC Advisor, maybe my powert supply is faulty? Help would be much appreciated...

  Fruit Bat /\0/\ 17:34 PM 23 Sep 11

HAve a look in disk management can you see it there?

Right click My computer - Manage - Storage - Disk Management

  soulboy 17:39 PM 23 Sep 11

No. Last time I couldn't gain access to the drive I could see it there, but this time it's completely invisible. I have recently re-installed windows.

  Graphicool1 18:27 PM 23 Sep 11


Have you tried plugging it into a different USB port? This has sometimes worked for me in the past.

  Fruit Bat /\0/\ 18:27 PM 23 Sep 11

try plugging into a different USB port

also check in device manager that you have an enhanced driver under USB heading

  soulboy 19:27 PM 23 Sep 11

Thanks fruitbat, you are a star! It was somethi8ng really obvious that I would not have checked without your advice... the boloody thing wasn't plugged in, I must have knocked it out whilst re-routing some hi-fi stuff. Thanks mate! I'm so gormless!




This thread is now locked and can not be replied to.

Surface Pro 4 UK release date, price and specs: Thinner, lighter, faster with new Type Cover and Pen

1995-2015: How technology has changed the world in 20 years

Territory delivers realistic NASA screens for The Martian - as they will be in 20 years time

21 brilliant tips for Mac OS X El Capitan: The best new Mac features in OS X 10.11