keyboard language settings Win95

  docj 15:13 17 Jan 03
Locked
  docj 15:13 17 Jan 03

A friend has just inherited a PC with Windows 95 nstalled. Suddenly, for no apparent reason, the keyboard will only work on the American settings.I have tried to correct this via the Control Panel\ Keyboard\ Language options But it refuses to accept the English-British settings. I have checked that the correct .kbd files are in the Windows\ System folder and that the Regional settings are correct.
She was given a Win95 CD but when I try to run it it says that it is an older version to the one installed. Thus I cannot try the Add/remove windows components facility (not that I know if this would help).
Though not an unsurmountable problem it is rather annoying and is baffling me completely. Could there be a registry setting or something I could change to get it to accept the new settings.
Thanks

  Diemmess 15:51 17 Jan 03

You have checked Regional settings - as well as Keyboard settings (Control panel)?

If the UK English is really not available in Keyboard settings then you are stuck without the proper CD.

Isn't this the time to step up to Win98SE ? - that would be intensive for you masterminding the change, but so worthwhile.

  docj 18:52 17 Jan 03

I did mention that regional settings had been checked.
I have suggested upgrading but, as a newcomer and a silver-surfer to boot, that is a bit beyond her means at the moment though it may be the only option.
I still cannot understand why it should have happened just like that though.

  Wak 19:51 17 Jan 03

Hi Docj, I don't know if this will help as I run Win 98SE, but it may point you in the right direction.
Go to Start/ run/ type REGEDIT/ Click OK.
Go to High-Key Current User/ Keyboard Layout/ Preload.
Highlight Preload 1 and the data in right panel says 00000809. This is the code for the British keyboard layout
Highlight Preload 2 and the data in right panel says 00000409. This is the code for the American keyboard layout.

The various languages for the keyboards are listed under H-Key Local Machine/ System/ Current Control Set/ Control/ Keyboards Layouts.

The above may direct you to the required Registry in Windows 95 or you may be able to swap the numbers around somewhere.
Best of Luck.

  docj 20:06 17 Jan 03

Thanks. I will give it a go- looks promising.
J

  dahli 20:17 17 Jan 03

If the CD is a different version to the Win 95 installed dare I suggest a reformat and reinstall with the supplied Win 95 CD. This should give the option to select the correct keyboard setup. Suggest this as an option if the action suggested by Wak doesn't work.

Dahli

  docj 21:57 17 Jan 03

I shall certainly bear that in mind. Personally I would just alter the keyboard with little stickers but I am intrigued and want to get at the root of the problem. Thanks a lot everyone. Keep 'em coming.

This thread is now locked and can not be replied to.

Xiaomi Mi5s review: The Xiaomi flagship that could replace your Samsung, LG, HTC or Apple phone

1995-2015: How technology has changed the world in 20 years

Mental Canvas is a brand new drawing app that's quite unlike any other

New MacBook Pro 2016 review | MacBook Pro with Touch Bar review: Apple's super-expensive new…