keyboard buttons displaying the wrong characters

  mitey_won 16:51 08 May 05
Locked

On my old computer, any keyboard i use on it has this problem. When you press shift+2 you get ampersand - @ and when you press ampersand button with shift you get inverted comma - ".
It happened with old keyboard so i bought a new one (it was knackered anyway) and it still happens. Any ideas? I would imagine this is a system setting of some kind. Is there a fix?

OS: Winxp pro
Athlon 1 ghz
Logitech keyboard and mouse

  DieSse 16:55 08 May 05

The regional settings are wrong - go to the Control Panel - Regional and Languga Options - Check through the variuos settings on the variuos tabs, and change them all to UK English.

  Hamish 17:00 08 May 05

Try this.
To customize key sequences for input languages
Open Regional and Language Options in Control Panel.
On the Languages tab, under Text services and input languages, click Details.
Under Preferences, click Key Settings.
In the Advanced Key Settings dialog box, under Hot keys for input languages, click the action for which you want to change the key sequence, and then click Change Key Sequence.
If necessary, select the check box to enable an action, and then click the key sequence you want to use.
Click OK four times.
Notes

To open Regional and Language Options, click Start, point to Settings, click Control Panel, and then double-click Regional and Language Options.
The Key Settings button is available only if you have added multiple languages or keyboard layouts.
Related Topics

  mitey_won 21:12 08 May 05

tried going thru the settings. No luck, changed everything from US to UK but still same problem. Can't imagine that generating the wrong symbol from the characterset would be something that could be cured from changing US to UK settings.
Any other suggestions?

  DieSse 22:22 08 May 05

After the change to UK settings - remove the US settings.

These settings are precisely to change what you need - in a US keyboard the symbols are where you are getting them, that's why you need to change them to sut your UK keyboard.

  Diversion 22:48 08 May 05

Try going to control panel, Regional and language settings. click on Languages then Details. You should have an "active services" box if are on XP Pro. Highlight the English (United States) and click on remove. BUT make sure that you have English (United Kingdom) in the "active services" box before you do so. It may only have English (United States) in your system

  mitey_won 19:32 09 May 05

yes, success! thanks for the tips, apologies to DieSse for doubting his word.
When i removed the US settings it worked. Have used these forums for a few years on & off, can't praise them enough!
thanks again.

  Newuser2533 22:38 02 May 06

Thanks for the advice, I've been going weeks without being able to change it.
Ron

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

This abstract video touches on division in our technologic world

Best alternatives to iTunes for Mac | Best music players for macOS: Free your music from the…