KERNAL_DATA_INPAGE_ERROR

  donatello 20:44 23 Apr 06
Locked

Having looked this up on the search help page on here it seems this is due to a fault with the Atapi.sys and Ataport.sys.Ive looked at the microsoft resolve page which says.Because Atapi.sys and Ataport.sys never run the _STM methodas long as there is I/O on the channel,the _STM method does not have to clear the IDE Decode Enable bit.Therefore BIOS manufactures should not clear the IDE Decode Enable bit in the _STM method.This is a bit confusing as a solution to this problem exactly what needs to be done to resolve the problem.The P/C is a home build with brand new Sempron 2800+ ASROCK K7VT4A PRO mainboard bios 1.05 refomatted and reloaded win XP downloaded all updates and service packs.Tried removing all software and running on just graphics card,mainboard setup 1 memory stick.This problem only seems to occur on running disk defragment programme or after the P/C has been left on for a while,dont think heat is a problem 2* 125 fans both running ok CPU temp about 39,Hard drive is a seagate barracuda 60gb nay input or solutions welcome.Thanks.

  george 23:08 23 Apr 06

Disable DMA then run defrag. Inpage errors can very often be linked to display problems and graphics cards. Even software that effects widows appearance (display properties) on screen can cause this type of error.
The problem is it could even be you CD/DVD ribbon connection that causes the problem. You seem to have tried most of what I would have. The only other thing is CPU heat and yours is well within the limits.
Not sure is this will help, but worth a look.
click here;en-us;303013
Cheers,
George.

  george 23:09 23 Apr 06

click here;en-us;303013

  george 23:10 23 Apr 06

have taken out the click here.

support.microsoft.com/default.aspx?scid=kb;en-us;303013

  george 23:28 23 Apr 06

Hi,

Have you looked here:

click here

  george 23:35 23 Apr 06

Switch on SMART in the BIOS and try HDD health.

click here

This should alert you to any drive probles, like heat etc.
That is about as much as I can think of at the moment. Seagate do have good checking software, link above so if that fails then look to the graphics card I think. Seagate also mention, and provide a download, to enable LBA 40 bit addressing for larger drives etc.

Cheers,
George.

  donatello 17:28 24 Apr 06

Thanks for ideas will try these tonight and let you know how it goes,its also being reported as KERNAL_STACK_INPAGE_ERROR is this pointing to the same problem.

This thread is now locked and can not be replied to.

Xiaomi Mi5s review: The Xiaomi flagship that could replace your Samsung, LG, HTC or Apple phone

1995-2015: How technology has changed the world in 20 years

Mental Canvas is a brand new drawing app that's quite unlike any other

New MacBook Pro 2016 review | MacBook Pro with Touch Bar review: Apple's super-expensive new…