Kaspersky Firewall and Google Earth

I have just downloaded Google Earth 5.0 and am having trouble running it. I also use Kaspersky Internet Security 7 and when I disable the fire wall, GE works fine. When I enable the firewall, I get the following error message - "Google Earth could not contact the authentication server to activate your session".

I have tried to configure the firewall, but don't seem to have any joy. I have reduced the security level from "High Security" to "Training Mode" and it seems fine, but I don't want to leave my machine vulnerable. I will probably be upgrading to Kaspersky 2010 shortly. I'm running Vista Home Premium SP1 on a Toshiba P300 laptop.

Can anyone help? Many thanks.

  Woolwell 12:09 25 Jul 09

I use Kaspersky 2009 and Google Earth 5 without any problems. Not sure about Kaspersky 7 but in 2009 you can go into Firewall settings and under applications edit the settings appropriately.

By the way you should try SP2.

This thread is now locked and can not be replied to.

How to get Windows 10 for free | How to install Windows 10: There is still a way to avoid paying…

1995-2015: How technology has changed the world in 20 years

Alex Chinneck’s giant ice cube Christmas tree at Kings Cross

Apple rumours & predictions 2017: The iPhone 8, new iPads, and everything else you should expect fr7…