Java exception message

  rickus 09:41 14 Oct 05
Locked

These were working yesterday morning but not in the evening.

I have a new PC and use XP SP2.

There are a couple of websites I got to that stream live share prices. they both require Java installed. Did that and they were working fine until yesterday evening.
One of them now just has a blank where the prices are normally shown except for a little icon in the top left corner.
The other gives this error message:
exception:java.lang.NullPointerException.

Have re-installed Java and it made no difference.
Am wondering if it could be my firewall, Zone Alarm.

Any ideas please?
Might installing Microsoft Java help?
Thanks
Rick

  kevinjuan 17:57 16 Oct 05

I have just experienced the same exception when trying to view the times crossword.

It has worked fine for a year but now I cant view it. Have tried reinstalling too, but made no difference. I also use Zone Alarm. Eagerly awaiting an answer.

  VoG II 18:01 16 Oct 05

Try running a test click here

  kevinjuan 18:18 16 Oct 05

Thanks for the link VoG but it didn't help. I am now getting another error: Applet Grid notinited.

Ive tried a google search but I don't understand the answers.

  rickus 20:04 16 Oct 05

Thanks for the suggestion VoG.

When I follow the link under Test your JVM a box appears below with a red cross in the top left corner.

Have tried all sorts of things and nothing has worked. One of the sites with the streaming prices, ADVFN, has an old version that does work. I guess it must be a combination of things causing it - partly the software on the websites I am using but also other software on my PC (as it had been working and then both ADVFN and another site's prices started failing at the same time). There is a long discussion thread on ADVFN about similar problems but no definitive answer.

  rickus 08:23 17 Oct 05

Have tried a number of things and got it working using the instructions below (newer versions of JRE now).
Now when it runs it downloads something automatically the first time I use it in a session.


'It's possible for 1.2.1 and 1.4.2 to co-exist. It depends on how the java applet is called in the HTML of the page loading it and a setting in IE.

First, you must disable the setting in IE that tells it to default to 1.4.2 for running all applets.

Go to Tools-->Internet Options-->Advanced and look for the Java check box. It should say something like, "Use Java 2 v1.4.2_02 for (requires restart)". Uncheck this.

By unchecking this, you have told IE that if an HTML page tries to run an applet using the tag, use IE's built in Java (1.2).'

This thread is now locked and can not be replied to.

Best phone camera 2016/2017: Galaxy S7 vs iPhone 7 vs Google Pixel vs HTC 10 Evo vs OnePlus 3T vs…

1995-2015: How technology has changed the world in 20 years

The Pantone Colour of the Year 2017 is Green

Super Mario Run preview | Hands-on first impressions of Super Mario Run: Mario's iPhone & iPad…