Is it safe to switch off like this?

  Sapins 15:12 21 Mar 11
Locked

The computer takes ages to switch off via "start" etc. Can I safely switch off by holding in the button on the tower, this only takes a few seconds.

  Nontek 15:16 21 Mar 11

It is safe, in fact this is a way of switching off in an emergency - holding down on/off switch for four seconds.

But I would not recommend regular use to switch off - better to just be patient, or to investigate why switch-off is taking so long.

  Graham. 15:18 21 Mar 11

Don't think it will adversely affect it, I sometimes do it when mine hangs at shutdown.

You will get an 'abnormal shutdown' message at startup, though.

  Nontek 15:27 21 Mar 11

There is a possibility of such a shut-down having an adverse effect - e.g. perhaps while Windows/Microsoft updates are being installed!

Though like you, I too have sometimes needed to shut-down in this fashion.

  theDarkness 15:56 21 Mar 11

Does it hang whilst in windows, or after the automatic log off when youve selected to shut down?
If the reason for the slow switch off or hang is because windows is trying to finish a task, which may include reading or writing, then there is always the possibility of data corruption or loss, however low the chance. How long has the problem been happening for, did you notice it after installing a specific program as an example, and does it always hang? If it happens again, try being patient to see how long it takes to switch off. If it hangs and you are still in windows you could try holding cntrl>alt>del to see if there any unwanted processes from programs still active

  Clapton is God 16:37 21 Mar 11

This may cure the slow shut down:

1- Start/Run and type Regedit
2- Navigate to HKEY_LOCAL_MACHINE/SYSTEM/CURRENT CONTROL SET/CONTROL
3- Click on “Control”
4- Select “Wait to kill service timeout”
5- Right click and select “Modify”
6- Set to a lower value than 2000
7- A setting of 200 will be sufficient

Normal setting is 2000 but can safely be reduced to 200 for a quick shutdown. Sometimes in PCs, including my own, an extra nought is added on to make it 20000. Not sure why this happens but when it does it leads to a very long shutdown time.

  Graham. 19:15 21 Mar 11

I don't have “Wait to kill service timeout”.

  Fruit Bat /\0/\ 19:20 21 Mar 11

No

What operating system?

  Graham. 19:21 21 Mar 11

Ignore that, looking in wrong column.

  Sapins 08:11 22 Mar 11

Thank you all for your replies.

I decided to time the shutdown and it was just on 2 minutes.

Clapton is God I have just changed the value to 200, it was on 20000! I will now try shutting down and see if there is any difference.

  Sapins 08:42 22 Mar 11

Shut down takes exactly the same time, I have searched Microsoft support but haven't found what the setting should be, I'll leave it at 200, any problems I'll re-set it to 2000.

Thanks again for all your help,

Regards,

Sapins.

This thread is now locked and can not be replied to.

Huawei P10 review

1995-2015: How technology has changed the world in 20 years

How VR is being used to simulate space

New iPad, iPhone SE & Red iPhone 7 on sale now