Is it just me?

  Jackcoms 18:38 02 Mar 05
Locked

Or is using this site like swimming in treacle tonight?

And I'm using a 1mb BB connection.

  Happy Soul 18:39 02 Mar 05

100% here in Kent. Blueyonder BB.

  VoG II 18:42 02 Mar 05

Screaming here.

  GaT7 18:48 02 Mar 05

No problems here - on Stone Age dialup ; ) G

  GaT7 18:51 02 Mar 05

Try clearing your Internet cache or use another browser to see if it made any difference. G

  Jackcoms 18:55 02 Mar 05

Internet cache cleared only this morning - and I'll stick with IE, thanks!

  Happy Soul 18:56 02 Mar 05

Wrong kind of snow? |:/

  CHAIRLEG 18:57 02 Mar 05

Ok here today was very slow yesterday

  Jackcoms 19:02 02 Mar 05

Must just be me or the snow or local contention ratios or the price of bread or whatever this evening.

Just done a speed test. Getting about 947 kbps downstream which is about my usual.

Ho, hum. Guess, I'll just live with it. :-)

  dogbreath1 19:27 02 Mar 05

This site has been playing up (at least as far as my p.c. goes) for the last few days. Hence my recent post. At one point yesterday, I couldn't even get into the log on page. Yet today it's quicker than it's ever been... it's like greased lightening... I can feel a song coming on!

This thread is now locked and can not be replied to.

Best phone camera 2016/2017: Galaxy S7 vs iPhone 7 vs Google Pixel vs HTC 10 Evo vs OnePlus 3T vs…

1995-2015: How technology has changed the world in 20 years

These are the Best Christmas Ads and Studio Projects of 2016

Super Mario Run preview | Hands-on first impressions of Super Mario Run: Mario's iPhone & iPad…