Issues With Internet Explorer

  Red Devil 18:23 14 Feb 14
Locked
Answered

Hi all,

I have been asked to sort out a friend's daughter's laptop and it has me stumped.

Basically, IE won't load. It starts to load, flashes on screen and then disappears.

I have checked up and this can be an issue with corrupted settings. The suggested solution was to run Microsoft's Fixit tool. That I have done but the issue remained.

At first, each time the laptop was booted up, IE was turned off and had to be turned on manually. That issue seems to have been resolved now.

I tried upgrading from the installed version of IE (10) to 11 (the laptop has Windows 7 Home Premium installed).

The installer won't run and gives the error message that a newer version of IE is installed.

I tried manually uninstalling IE via the uninstall Windows features facility. I was able to remove IE 10 and then 9 but when IE 8 installed it doesn't appear as an uninstall option.

So now I am at an impasse. I can't fully uninstall IE so as to do a clean install, I can't upgrade and IE won't load.

Does anyone have any suggestions/help as to what I can do next?

Thanks,

RD

PS, as a temp solution I have installed Firefox so that my friend's daughter can at least access the web for school work.

  rdave13 18:51 14 Feb 14

Have a look in system tools under accessories and find IE (No Add-ons). Open it then go to tools, internet options, advanced and then reset IE. Close it then reboot. Hopefully going back to IE 8 hasn't done any damage. You can't uninstall IE as it is part of the OS.

Once rebooted run Windows update.

  Red Devil 19:20 14 Feb 14

Tried that, it won't load IE even with the no add-ons option.

:(

RD

  rdave13 19:40 14 Feb 14

That means the OS is corrupted.

Try this, open the Start Menu, click on All Programs and Accessories, right click on Command Prompt, and click on Run as administrator. Type or copy and paste sfc /scannow and press enter. If it shows errors or not then close CMD and reboot. Repeat again and reboot. Try opening IE no-add-ons again. If it opens then do the reset as above. Run Windows update.

  jaywoo 19:43 14 Feb 14

You can reset IE without having to load it, look in Control Panel/Internet Options.

Also open a command prompt as admin, type

SFC /scannow

to check system files.

Look in Event Viewer for errors occurring when you try to start IE, might give you some clues - Start Menu, right click Computer, select Manage, on the left hand side of the new window expand Event Viewer, then expand Windows Logs, you'll most likely find something pertinent under the Application log, possibly something in System too.

Also, without knowing what other scans you've done, update and full scan with existing antivirus, Malwarebytes Antimalware, perhaps TDSSKiller, HitmanPro free. If something got in and deliberately damaged IE it might still be lingering. SuperAntiSpyware (also free) has a handy "repairs" section that might help too.

  rdave13 19:50 14 Feb 14

PS, I haven't suggested System Restore yet as the damage might have occurred removing a virus/malware from the machine. If the above doesn't work and you go for a restore then go well beyond when this error happened. Be aware that you will have to save any new documents/files before you do this and scan them for potential malware.

  Red Devil 16:17 15 Feb 14

Hi all,

Thanks for the help. I ran the scan as suggested but IE still won't load. I have been in the Event Log and this is the error that gets reported when I try and run IE:-

"Faulting application name: iexeplorer.exe version 9.0.7601.17514, time stamp: 0x4ce79912 Faulting module name: KERNELBASE.dll, version: 6.1.7601.18015, time stamp: 0x50b83c8a Exception code: 0xc06d007f"

If anyone can help with this I'd be grateful but it's time to go Googling too. ;)

RD

  rdave13 16:33 15 Feb 14

Run Ccleaner and it's registry cleaner first. Here are a list of updates to install before installing IE 11. Try manually installing each one. Check the bit version. Reboot. link. Go to File Hippo and download IE 11 manually. If a box shows to download prerequesits update then untick and carry on installing.

  rdave13 16:35 15 Feb 14
  Red Devil 16:47 15 Feb 14

Hi all,

Well, we seem to be getting somewhere - the IE 11 install is actually working now without failing with an error saying a more recent version is installed.

Will let you know if the issue is sorted and thanks for the help all. :)

RD

  rdave13 16:55 15 Feb 14

Shot in the dark here but not the same Red Devil as was in Avmechanic years ago?

This thread is now locked and can not be replied to.

The Legend of Zelda Breath of the Wild review: Five hours with Zelda on the Nintendo Switch

1995-2015: How technology has changed the world in 20 years

How the painting-like animated sequences in A Monster Calls were created by Glassworks Barcelona

The 22 best Safari extensions | Best Safari plugins: Improve Apple's Safari web browser with these…