IP Address Missing

  Dazed&Confused 22:38 19 Apr 06
Locked

Last night I had to reinstall the wireless adaptor for our 2nd pc but the IP address is missing so I have no connectivity. I tried the repair option but it has failed. I've also tried to reinstall the broadband software in the hope that would help but no joy. How do I get the IP address reinstated?

  mgmcc 23:59 19 Apr 06

The adapter gets its IP address from the router by DHCP.

Have you actually "Connected" to the wireless network? In other words, have you run the wireless adapter's software, scanned for "Available Wireless Networks", found and highlighted the one that matches your router's SSID (network name) and selected the option to "Connect" to it? Once "connected", the wireless adapter should get its IP address by DHCP from the router and you should have network and internet access.

  Dazed&Confused 06:14 20 Apr 06

Thanks. Yes I have highlighted the one that matches my routers ssid and run the repair option to re-instate the IP address but it fails.

  mgmcc 10:13 20 Apr 06

Connecting to the wireless network and "repairing" the connection are two separate actions. Does the wireless software definitely show that you are "Connected" to the network with your router's SSID?

If you are connected and the adapter still fails to get its IP address, check in the router's settings that DHCP is enabled.

  Dazed&Confused 12:57 20 Apr 06

yes it is connected and signal strength is excellent but the status says little or no connectivity. there is another icon in the system tray with two monitors with a red cross over it, the message reads lan cable not connected. there never has been a lan cable on that pc as it is wireless. no cables are disconnected on the main pc or router.

How do I check the router's settings for DHCP?

  mgmcc 18:17 20 Apr 06

<<< yes it is connected and signal strength is excellent but the status says little or no connectivity >>>

The fact that the signal strength is excellent doesn't mean that you are "connected". Does the little icon have its "halo" per this screenshot? click here

<<< there is another icon in the system tray with two monitors with a red cross over it, the message reads lan cable not connected >>>

If the computer has a network adapter installed and it isn't connected to anything (a hub/switch/router or another PC) this icon with the red cross will normally be displayed. You can remove it by right clicking the Local Area Connection in the Network Connections folder and selecting Disable.

<<< How do I check the router's settings for DHCP? >>>

That will vary from one router to another, but if one of your PCs is getting its IP address by DHCP (i.e. you haven't allocated a fixed IP address) then the router's DHCP server must be functioning.

  Dazed&Confused 18:38 20 Apr 06

Hi, yes the halo is there. I have a hub manager icon on my desktop I'll look in there.

  Dazed&Confused 20:14 20 Apr 06

In the private network settings it shows the default ip address and the enable dhcp box is greyed out as follows:

Private Network
If you change the IP address range, you must renew the DHCP lease on all devices on the network.


192.168.1.0 / 255.255.255.0 (default)
172.16.0.0 / 255.255.0.0
10.0.0.0 / 255.255.0.0
Configure manually
Router Address:

Subnet Mask:

Enable DHCP
First DHCP Address:

Last DHCP Address:


Set DHCP Lease Time: 24 hours



If I click on configure manually I have to enter the router address, sub mask, tick the enable dhcp box and the first and last dhcp addresses (are the first and last addresses the ones shown next to dhcp range below?).

The current settings are:

Private Network
Router Address: 192.168.1.254
Subnet Mask: 255.255.255.0
DHCP Range: 192.168.1.64 - 192.168.1.253
Allocated: 2
Available: 188

Bridge Network
Bridge Address: 86.130.101.203
Subnet Mask: 255.255.255.255

Device List
C2E3U2 192.168.1.64
Dan 192.168.1.65

  mgmcc 22:38 20 Apr 06

That suggests that the router has allocated the IP addresses 192.168.1.64 and 192.168.1.65 to the two "client" PCs.

However, try giving the problem PC fixed addresses and see if that helps:

IP address - 192.168.1.50 (to keep it outside the router's DHCP "pool")

Subnet Mask - 255.255.255.0

Default Gateway - 192.168.1.254 (the router's IP address)

DNS Server address - 192.168.1.254 (the router's IP address)

  Dazed&Confused 17:01 22 Apr 06

Thanks for all your help. Sorry to appear incredibly thick but where do I enter the info you gave me? On the hub manager? If so I don't have boxes to enter all that info. If I want to configure manually I only have:

Router Address:

Subnet Mask:

Enable DHCP
First DHCP Address:

Last DHCP Address:

Or do I input it on the problem pc, if so where?

Saw this elsewhere on this site and have tried:

run, (type) cmd, ok, (type) ipconfig/release then ipconfig/renew

also tried: run, (type) cmd, ok, (type) ipconfig

Each time it won't let me input anything on screen.

Also on hub manager (on main pc) the ip address shown as the default for the problem pc is: 192.168.1.0 / 255.255.255.0 (default)

but when I've tried the repair option on the problem pc it is: 169.254.131.84

I can't find the driver cd rom at the moment but if I did would it be best to uninstall the wireless adaptor and reinstall? Am losing my patience with it and the kids are doing my head in too!

Thanks again mgmcc for all you help.

  mgmcc 17:24 22 Apr 06

<<< where do I enter the info you gave me? On the hub manager? If so I don't have boxes to enter all that info >>>

In the PC, open the Network Connections folder, right click the "Wireless Network connection" and select Properties. Highlight "Internet protocol (TCP/IP)" and click the Properties button.

Click "Use the following IP address" and enter the settings I suggested.

This thread is now locked and can not be replied to.

What is Amazon Go and will it come to the UK? The store without checkouts or queues

1995-2015: How technology has changed the world in 20 years

Why ecommerce hasn't taken off on social media

New MacBook Pro 2016 review | MacBook Pro with Touch Bar review: Apple's expensive and powerful…