IOMEGA 500gB Desktop Hard Drive

  boustrophedon 11:59 17 Apr 09
Locked

I bought an IOMEGA 500gb Hard Drive to used with an Advent T9100 Desktop and a Fujitsu Siemens Amilo Laptop. According to the box it is easy to install.

Although I get the familiar ping when it is pluged into a USB port it is otherwise more or less invisible with the result that it is unusable. The IOMEGA web-site is of a similar standard as no telephone number is visible. Having failed to locate a driver (as the model number on the box could nto be found on the web-site!) I made one attempt to submit a query and received a response that referred me to a form to complete that was not a form but an endless spiral of alleged contact methods.

Entering the serial number indicated that it was a 60gb portable drive!

I am returning it to store for a refund as ast best it can be described as totally and utterly useless and not fit for purpose.

  Woolwell 12:56 17 Apr 09

With XP (which I guess you have) or Vista you should not have to install drivers as it should be plug and play.
Does it have it own power supply or does it draw from the USB port?
Have you tried different USB ports and what shows up in Device Manager?

  boustrophedon 13:10 30 Apr 09

I returned the drive to my supplier and it would not install on one of their systems and they agreed it was faulty.

As the IOMEGA web-site was unhelpful and in any case 500gb is a lot of space most of which will probably never be used I decided to go for a 250gb drive from another manufacturer driven off the USB port as this aids portailty and does not require a mains lead.

This thread is now locked and can not be replied to.

What is Amazon Go and will it come to the UK? The store without checkouts or queues

1995-2015: How technology has changed the world in 20 years

Hands-on with the Star Wars fighting drones you can fly yourself

15 macOS Sierra tips | How to use macOS Sierra: Secret tricks and best new features in Apple's new…