Invalid "command.com"

  pj123 14:23 02 Aug 03
Locked

I have a "Tiny" (I know, I know)computer in for repair. It doesn't work. The POST runs OK then I get "Verifying DMI pool data....." then Invalid command.com enter correct name of Command Interpreter (eg. C:\command.com)

I have searched the hard disk (via DOS) and the command.com file is there and at the correct size. I have tried another known working hard drive and get the same problem. The Motherboard is AOpen. 400mhz amd processor, 128mb sdram memory and 8.4gb hard drive. I have also deleted the command.com file and copied another from a working system. Still the same error.

  Wak 15:53 02 Aug 03

I don't know if this will help you but in Win 98SE with IE 6.0 there are three Command.com files
all at 92Kb.
One in C:\, one in C:\Windows and one in C:\Windows\Command\EBD.

perhaps the problem does not lie in the command.com but in a line in either your config.sys file or autoexec.bat file making a call to the command interpreter and finding the wrong version.

  pj123 17:56 02 Aug 03

I have deleted both the autoexec.bat and config.sys files and rebooted. still got the same problem. the computer does not get as far as that anyway.

  woodchip 18:14 02 Aug 03

Start with Win98 boot floppy at A:\ type SYS C:

  pj123 12:39 03 Aug 03

I have just put in a known working hard disk with Windows 98se installed on it and still get the same problem. Someone suggested the AOpen motherboard is to blame. What throws me about that is, what has a motherboard BIOS got to do with command.com? As the POST finishes I get a Windows 98 splash screen then the "invalid command.com" error. I can get into the A prompt with a boot disk OK and can see all the files on the C: drive. I will try and re-install windows over the top.

  DieSse 12:45 03 Aug 03

Might it be trying to read from the A: drive first, even tho' there is no diskette in it?

  jazzypop 12:59 03 Aug 03

I think Diesse has probably got it right - your BIOS is not set to boot to the HDD first.

However, if it already is set to boot to the HDD, have you tried changing the BIOS to boot from the floppy drive first, then boot to a W98 boot floppy? Choose 'boot to DOS' or hit shift-F5. At the command prompt type

fdisk/mbr

This will repair a damaged master boot record on your HDD.

If still no joy, boot to the W98 floppy again, at the DOS prompt, type

sys C:

and press enter. This will copy the system files to the HDD.

  woodchip 15:48 03 Aug 03

Yep as jazzypop

  pj123 10:01 04 Aug 03

Thanks everyone. But now it doesn't boot to DOS using the boot floppy. I get as far as "shift F5" and then I get "invalid command.com" again.

I am going to try a new (different) motherboard and see what happens, although I am still convinced that this has nothing to do with the M/B.

  Gaz 25 11:25 04 Aug 03

Could this be a virus?

There is a virus that does overwrite command.com and even create some.

Run a virus scan!

This thread is now locked and can not be replied to.

How to get Windows 10 for free | How to install Windows 10: There is still a way to avoid paying…

1995-2015: How technology has changed the world in 20 years

Alex Chinneck’s giant ice cube Christmas tree at Kings Cross

Apple rumours & predictions 2017: The iPhone 8, new iPads, and everything else you should expect fr7…