Internet Sharing help please

  Ray5776 15:59 01 Dec 05
Locked

Hello.
I have recently networked 2 Win2000 machines with a great deal of help from this site. The final thing I need to do is set up the internet sharing, I have read through pages of the forum and various other books and articles. I thought this would be the easy
bit but I seem to be doing something wrong, just cant get it to work. Any suggestions please.

Ray

  mgmcc 19:25 01 Dec 05

You need to enable "Internet Connection Sharing" on the actual internet connection (modem connection) in the "Host" PC. This will automatically configure the PC's network adapter (that connects to the "Client" PC) with the fixed IP address 192.168.0.1 and subnet mask 255.255.255.0

The "Client" PC's network adapter is set to get its IP address automatically, which it does from the "Host" PC. If you have been networking without Internet Connection Sharing, you may have allocated a fixed IP address to what is now the "Client" PC, so this setting should be changed.

Any firewall software needs to be configured to allow access to the networked computers by entering their IP addresses in its "trusted" area. Also, if you should be using Zone alarm in the "Host" PC, you need to reduce the Internet Zone Security level from High to Medium or I.C.S. traffic will be blocked.

  Ray5776 20:27 01 Dec 05

Hi Thanks mgmcc,
I have enabled ICS on the host connection (wanadoo speedtouch).
The firewall Zone Alarm is set to medium and I have entered the IP address of the client 192.168.0.24 in the trusted area. The host is 192.168.0.1. What I understand that I should do with the client is
start/settings/network & dialup cons/lan/properties/general/internet protocol/general. When I get to the general tab it says obtain IP address automatically, same for DNS.
There is nothing displayed in the boxes, if I click OK Local Area Connection Properties closes if I reopen it, it is still blank, should it have an address in it or is it supposed to be blank.

Ray

  Ray5776 20:32 01 Dec 05

Sorry missed part of your post mgmcc,
How do I know if I have a fixed IP address on client? and if I have how do I change it and what to.
Thanks Ray

  mgmcc 20:44 01 Dec 05

<<< There is nothing displayed in the boxes, if I click OK Local Area Connection Properties closes if I reopen it, it is still blank, should it have an address in it or is it supposed to be blank. >>>

That's absolutely correct. You have set it to get the addresses automatically so there are no addresses displayed in the boxes.

If you open a Command Prompt window and type the command:

IPCONFIG /ALL

this should display details of all adapters in the PC, including their IP etc addresses.

  Ray5776 20:54 01 Dec 05

Hi again, IPCONFIG/ ALL shows
WINS Proxy enabled=No
DHCP enabled=Yes
Autocon fig=Yes
IP Address 192.168.0.24
Default Gateway/ DHCP server?DNS servers all 192.168.0.1
and some other stuff.
What next/

Tanks Ray

  mgmcc 21:06 01 Dec 05

<<< What next >>>

...erm, the computer should actually be online. If the Host PC is online, then the client PC should now have internet access.

What I would suggest with Zone Alarm, which I assume you have in both PCs, is to open the Zones tab and click "Add" then select Subnet. Enter the IP address 192.168.0.0 and Subnet Mask 255.255.255.0

This will allow access to any IP addresses in the 192.168.0.1 to 192.168.0.254 range, so it won't matter if the Client PC's IP address changes.

  Ray5776 21:20 01 Dec 05

Hi thanks,
I only have Zone alarm on the host. I have entered the IP address earlier, to enter the subnet mask do I use / after the IP or do I do it as a separate entry?
I am almost there, this is going to be some silly little thing that I have overlooked.

Ray

  mgmcc 22:07 01 Dec 05

In Zone Alarm, if you select "Add" then "Subnet" the box that opens has 3 entries (you can't change the Zone - Trusted entry).

Type 192.168.0.0 in the IP Address line

Type 255.255.255.0 in the Subnet Mask line

Type {anything} in the Description line, but it needs an entry

Click "OK" to close that box and then click "Apply" to save the settings. The entry will appear in the format 192.168.0.0/255.255.255.0 with Subnet as the Entry Type.

Also note my earlier comment:

If you should be using Zone alarm in the "Host" PC, you need to reduce the Internet Zone Security level from High to Medium or I.C.S. traffic will be blocked.

  Ray5776 22:38 01 Dec 05

Hi,
Entry in Zone alarm says
ray-w5k391 pqvyc (the name of the client)
192.168.0.24/255.255.255.0. subnet/trusted.
I just cant see why it wont work, the same 2 machines have been networked before, all i have done is put win 2000 on client when it used to use win ME.
Ray
(set @ med firewall))

  mgmcc 23:10 01 Dec 05

<<< Entry in Zone alarm says
ray-w5k391 pqvyc (the name of the client)
192.168.0.24/255.255.255.0. subnet/trusted. >>>

If you are entering a "Subnet", the IP address should be 192.168.0.0 (with zero as the last octet) not an individual PC's IP address. However, that is unlikely to be the problem.

What indication are you getting that the "client" isn't online? For example, if your web browser says page cannot be displayed, can your email program access the POP3 server to check for new messages or does that fail too?

Something else to try:

Run IPCONFIG /ALL in the "Host" PC and make a note of the DNS Server addresses allocated by the ISP.

In the "Client" PC, for the Local Area Connection's TCP/IP settings, click "Use the following DNS server addresses" and enter the addresses you noted from the Host PC. Don't change the IP settings though.

This thread is now locked and can not be replied to.

How to get Windows 10 for free | How to install Windows 10: There is still a way to avoid paying…

1995-2015: How technology has changed the world in 20 years

Alex Chinneck’s giant ice cube Christmas tree at Kings Cross

Apple rumours & predictions 2017: The iPhone 8, new iPads, and everything else you should expect fr7…