Internet sharing

  Gaz_dc 22:24 26 Dec 04
Locked

I have a wireless network at home which works perfectly. Downstaires, I have the router and my PC (Win XP Home) is upstairs with my wifes laptop being anywhere she fancies surfing (usually as far away from me and my heavy metal music as possible!).

The problem is that I am trying to set up an old PC I have acquired for the in laws. I have connected this PC (Win 2K) to mine with a cross over cable and can share files fine. But I can't seem to set it up to allow this PC to access the internet. When I tick allow sharing, Win XP insists on giving my PC an IP address of 192.168.0.1, which is the IP address of my router and I don't think this can be changed. Is there anyway to enable sharing without XP re-setting my IP address?

  JaßîsFaß ˜ 23:16 26 Dec 04

I would get a wireless adaptor for the in-laws PC, and get it to connect via the router for internet, and then set up a wireless network for sharing files.

  Gaz_dc 23:24 26 Dec 04

This is only a temporary situation, it is not worth the cost of the wireless card. Plus, I am hoping to learn if it possible to set the PCs up in this configuration!

  LastChip 23:46 26 Dec 04

The problem you have, is you are trying to effectively use two DNS servers - your Router and Windows XP.

So, let your Router configure XP's address and make sure you can access the Internet on that machine.

At the command line (Start; Run) type the command;

ipconfig /all

This should show you the address your Router has allocated to the XP Network card. Maybe a 192.168.x.x or perhaps 10.0.x.x address. If it's a "192" address, the subnet will be 255.255.255.0 but if it's a "10" address, the subnet will be 255.255.255.255

Assuming you are using Internet Explorer on the W2K machine to try and access the net, on that machine, go to Tools; Internet Options; Connections; LAN Settings; Tick the box "Use a Proxy Server" and enter the address of your XP machine in the opened window with Port 80 selected under ports and click OK.

Now see if you have access.

  AndySD 23:46 26 Dec 04

Set the old pc with the default gateway the same as the IP address on the XP pc.

  Gaz_dc 11:08 27 Dec 04

Tried all of the above suggestions but just keep getting 'The page cannot be displayed' in IE. Any other ideas anyone?

  LastChip 12:39 27 Dec 04

click here and download the Proxy Server.

Install according to the help file and configure your W2K machine to access the proxy.

  Gaz_dc 23:43 28 Dec 04

Excellent, that Proxy Server works like a dream!

Thanks everyone for the help and thanks LastChip for the solution!

Hope you all had a good Christmas and Happy New Year to you!

Gaz

This thread is now locked and can not be replied to.

Best phone camera 2016/2017: Galaxy S7 vs iPhone 7 vs Google Pixel vs HTC 10 Evo vs OnePlus 3T vs…

1995-2015: How technology has changed the world in 20 years

Best Christmas Agency Projects of 2016

Super Mario Run preview | Hands-on first impressions of Super Mario Run: Mario's iPhone & iPad…