Internet Explorer 9 recent problems with loading webpages and slow responses

  Jimbo4 21 Jan 13
Locked

I am running windows 7 with Internet Explorer 9 update version 9.0.12(KB2761465) all was working O.K. until about 6 weeks ago when some pages do not load correctly and the response from some sites is very slow. I have downloaded and installed Google Chrome to compare and all works O.K. using Chrome. Have I got a corrupted update ? in explorer 9 and if so how do I check and sort it out?

  Jimbo4 21 Jan 13

Jockie

Thanks . I thought IE 10 was not fully compatible with windows 7. IE 9 is fully updated from automatic windows updates. No outstanding updates are listed. Worked fine until around 6 weeks ago

  Woolwell 21 Jan 13

IE10 is only at Release Preview stage for W7. Doubt that it will solve the problems. Try reset as Jock1e has suggested. Try running with out add-ons (accessed through all programs, accessories, system tools) and see if it is ok then. Try the problem sites in compatibility mode. Lastly stick with Chrome which IMO tends to to be better.

  Jimbo4 21 Jan 13

Jockie

Many thanks have now tried the "reset" option and it seems to have cured the problem

jimbo4

Advertisement

This thread is now locked and can not be replied to.

Should I upgrade to Windows 10? 8 reasons why you should upgrade to Windows 10... and 2 why you…

We are being sold the ability to spend money we don't have. And we love it

See 24 hours in London with Paul Richardson's hyperlapse tour

How to use Apple Music in the UK: Complete guide to Apple Music's features

We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message