Internet connection sharing W98SE & XP Pro

  johnem 20:54 02 Jan 06
Locked

Hi gang, back for some more advice. I have XP Pro SP2 running on my desktop and connecting to broadband via a Voyager 105 modem.I have network my desktop to a laptop running W98SE using a crossover Cat 5 cable and a PCMIA card. Both computers can see each other and share files. The desktop has been set up to allow internet connection sharing.
For convenience, the desktop has the network bridge working with a fixed IP of 192.168.0.1 and subnet mask of 255.255.255.0. I have set the default gateway as 192.168.0.1. On the laptop I have set the IP as 192.168.0.3 with subnet mask of 255.255.255.0 and the gateway as 192.168.0.1. Both machines run Zonealarm 6.1.737.000 and the internet setting of the firewall has been set at medium. Both have had the range 192.168.0.1 - 4 set as trusted.
The problem is that the laptop is not able to access the internet, despite being able to create the gateway connection by clicking on the systray icon. Whenever I try to go to Google or any other website, it eventually returns the "Page cannot be displayed" message, even though the modem is online and working.
Is there a simple way that i can adjust the settings to give shared internet connection.

  Taff™ 00:13 03 Jan 06

In IE Tools>Internet Options>Connections Tab and then the LAN button. I think both boxes have to be cleared. Close IE and restart it.

  Strawballs 01:14 03 Jan 06

Have you tried running the network connection wizard in control panel on the XP machine and making the floppy or cd when it asks and using that to configure the 98 machine. That is what I did with my first attempt at networking with crossover cable and XP to 98 and everything worked OK

  mgmcc 09:08 03 Jan 06

<<< For convenience, the desktop has the network bridge working with a fixed IP of 192.168.0.1 and subnet mask of 255.255.255.0. >>>

What connections do you have "bridged" and why do you need a "bridge?

The addresses you quote are not "for convenience", they are the essential ones for an Internet Connection Sharing "Host" PC, but should have been allocated automatically by Windows when you enabled ICS on the actual internet connection (modem connection), you should not have had to enter them yourself.

<<< On the laptop I have set the IP as 192.168.0.3 with subnet mask of 255.255.255.0 and the gateway as 192.168.0.1 >>>

Again, you shouldn't have entered the addresses yourself. When you enable ICS in the "Host" PC, Windows enables it as a DHCP server to allocate the addresses to the "Client" PC - IP address, Subnet Mask, Default Gateway and DNS Server. The "Client" PC's TCP/IP settings should be set to get the IP address automatically.

Although the Client PC addresses can be configured manually, "Internet Connection Sharing" often doesn't like fixed client IP addresses and can fail to work when set up this way.

  johnem 21:15 03 Jan 06

Thanks to Taff, Strawballs and mgmcc for all of your helpful suggestions. I have gradually implimented them all and now the network and ICS works.
As to the bridge, I obviously must have misunderstood the instructions when originally using the wizard, as I thought that the bridge was needed to link between my network card and the 1394 built in adapter.
Tahnk you for all your help.

This thread is now locked and can not be replied to.

The Legend of Zelda Breath of the Wild review: Five hours with Zelda on the Nintendo Switch

1995-2015: How technology has changed the world in 20 years

How the painting-like animated sequences in A Monster Calls were created by Glassworks Barcelona

The 22 best Safari extensions | Best Safari plugins: Improve Apple's Safari web browser with these…