Internet Connection Sharing problems

  Gaz W 15:21 25 Jan 04
Locked

I am trying to set up ICS with a Windows 98 desktop (host) and an XP Home laptop (client). They are connected with crossover cable and the network is working with the host's IP address set to 192.168.0.1 and the client's is 192.168.0.2.

ICS is installed, but when I enable it (using the icon in system tray) the internet connection doesn't work on the host. What's the cure?

  Gaz W 15:32 25 Jan 04

P.S.

Forgot to mention it's NTL:home broadband & the cable modem is USB.

  Gaz W 21:08 25 Jan 04

It turned out that the firewall was the problem, as usual. ZoneAlarm Pro has to be set to Medium security for the Internet Zone for it to work. When it's on Medium, the Internet works on the host and the client, but when it is set to High security in the Internet Zone, the Internet won't work on the host or the client unless ICS is disabled!

The problem with leaving the firewall on Medium is that it says "This setting is recommended for temporary use....."

It's the Temporary part I don't like the sound of. I know you can click Custom, but what custom settings can I select to make it more secure than medium but not so secure that it blocks the internet connection? Or is it OK just on medium?

  johnem 21:55 25 Jan 04

Gaz W, have had similar probs in the past and recently found that to get ICS to work I had to set 192.168.0.1 and 192.168.0.2 up in the "trusted zone2" area of ZA. Go to the 'Firewall' tab, select 'zones' click on 'add', click on IP range, leave the default as 'Trusted' then add the first IP number to the first line, the second IP number to the second line and give the whole effort a title in the last line, lcick on 'OK' and 'Apply'. You may well find that this helps to cure the problem.
Otherwise you will have to resort to reduce the firewall to medium. It still works very well but obviously it is not in full stealth mode.

  Gaz W 22:46 25 Jan 04

Have set an entire IP range - 192.168.0.0 to 192.168.0.255 and the problem is still there when it's on High security. It looks like it might have to be on medium mode.

Obviously there are a few differences in the protection between medium and high. You can customise the security settings so that you get an "in between" security level. If I can find out exactly what High is blocking that is stopping the internet connection, I can customise it to allow that thing if you know what I mean.

Anyway thanks for the reply.

Gaz

  Gaz W 23:12 26 Jan 04

I'll tick the Resolved box now - it's OK on medium - well, it's not been hacked anyway!

Thanks for your suggestions.

Regards, Gaz

This thread is now locked and can not be replied to.

How to get Windows 10 for free | How to install Windows 10: There is still a way to avoid paying…

1995-2015: How technology has changed the world in 20 years

Alex Chinneck’s giant ice cube Christmas tree at Kings Cross

Apple rumours & predictions 2017: The iPhone 8, new iPads, and everything else you should expect fr7…