Internet Connection Issues - Big Problem

  shrew82 13 Dec 12
Locked

I've been having problems connecting to the internet for over a week now and i've tried pretty much everything to sort it out. On Sunday, i contacted my ISP who advised me that it was a problem with my Channel settings on the router. I changed to the settings that they suggested but with limited or no success. Some sites connect pretty much straight away, other sites appear really slow, and some don't work at all, including google and hotmail (similar problems on other devices and not just my laptop).

Anyways, after reading many blogs about the potential problems, it looked like my router could be the cause of the issues, and as it was pretty old anyway, i decided to invest in a new one which, although appears to have improved the speed of the network, hasn't helped the main problem i was experiencing with my old router.

I was wondering if anyone could help me further as this now appears to be a network problem and not a problem that i can fix readily, however i was wondering whether a virus could of infected my network rather than the PC and if this was the case is there any way of removing it?

Any help would be greatly appreciated as this is starting to irritate me! thanks

NB: I have just got off the phone from my ISP (for a second time) who were extremely unhelpful for about 40 minutes and finished by hanging up on me... i called them back, but they haven't been able to fix my problem! If you need any more information please ask.

  difarn 14 Dec 12

Which OS are you using? Do you have any other pc's that are connecting ok? Are your wireless and ethernet drivers up to date - check in Device Manager?

Some simple things to try.

I assume that, because your ISP advised you to change channel settings on the router, that this is a wireless connection. If so, have you tried to connect using an ethernet cable.

It could be that your router is not allocating an IP address to your PC. If you have just a router:-

Turn off all PC's, disconnect the power to the router and the router from the PC if you had an ethernet connection. Boot up a pc, restore power to your router. Connect the pc by ethernet to your router and wait.

If there is still no connection right click on your ethernet adapter, disable it and re-enable it.

  mgmcc 14 Dec 12

" Some sites connect pretty much straight away, other sites appear really slow, and some don't work at all, including google and hotmail"

What happens if you type 173.194.78.94 directly into the address bar of your browser? It should open Google's webpage and if it does, but the alphabetical address doesn't work, that would suggest a DNS issue.

  Forum Editor 16 Dec 12

"Some sites connect pretty much straight away, other sites appear really slow, and some don't work at all"

Is it always the same sites that give trouble,and if it is,which ones?

Try this: Hold down the Windows key on your keyboard and press the R key. Type: ipconfig /flushdns into the box and press the enter key.

If that doesn't help,try disabling your firewall to see if that makes a difference.

There could be any number of reasons for this problem, it's a question of trial and error.

  edd78 20 Dec 12

hi shrew82

i had the same problem as you have described i got hold of dell throw the support forums i they sent my laptop away to get a new wireless card and it worked ok after that

Advertisement

This thread is now locked and can not be replied to.

Should I upgrade to Windows 10? 8 reasons why you should upgrade to Windows 10... and 2 why you…

We are being sold the ability to spend money we don't have. And we love it

Encore creates eerie effects for Spielberg's new TV show The Whispers

How to use Apple Music in the UK: Complete guide to Apple Music's features

We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message