Installing Belkin G+ MIMO Modem Router F5D9630

  Muttaburrasaurus 09:21 17 Nov 07
Locked

I have just been trying to install this device with a Virgin Net Broadband account. I looked at the other threads on this site but none seemed to help. I was sure I had everything set up right, but the modem couldn't connect to the ISP.

Managed to get through to Belkin Technical support (no wait!) and they fixed it.

They told me to open internet explorer, click cancel on the dial up screen, then go to the Tools menu, Internet Options, Connections tab, then click the 'Never Dial a Connection button'. Open a new Explorer window and it worked OK.

Hope this helps if you are having problems.

This thread is now locked and can not be replied to.

Intel Coffee Lake 8th-gen Core processors release date rumours

1995-2015: How technology has changed the world in 20 years

Framestore’s haunting post-WWII title sequence for new BBC series SS-GB

Best iPhone games 2017 | Best iPad games 2017: 162 fantastic iOS games that you need to play right…