infuriating printer problems

  zaz 16:22 15 Dec 07

hej hej

My printer - a Canon MP500 - went wrong, so it was sent back to the makers for repair.

All I did was unplug the machine and take it in to be mended.

Now , on its return , I cant print out - it keeps coming up with messages like 'Printer is not online!'

ALL the plugs are back in the same place and I have nothing different ..............

The repairer said they replaced a logistic board ...... - means nothing to me !

I am so frustratated with this blessed printer - now what am I doing wrong ??

any ideas!

I do not want to uninstall and reinstall as I am so unsure of all this stuff .........


  howard64 16:46 15 Dec 07

assuming this is a usb connected printer try unplugging it and plugging it in to a different usb socket. If this does not work you will have to go through the uninstall reinstall routine. Click on start - settings - printers and faxes - highlight the name of your printer and right click on uninstall. Restart your pc and the printer should be recognised and reinstalled. It might now work.

  zaz 16:55 15 Dec 07

I have now tried it in three other usb ports and still no joy - it comes up with the message 'Checking printer status' ........

do I have to uninstall????

  Fruit Bat /\0/\ 16:56 15 Dec 07

Refresh USB Ports
In device manager Uninstall EVERYTHING under the heading USB,
reboot the PC let XP find and install new hardware.
Your equipment should now be recognised.

  zaz 17:31 15 Dec 07

hej hej

I uninstalled the printer and have now reinstalled again - but according to my 'control panel' I have a Canon Image Writer - a Canon copier ' but no Canon Printer?????

Before I started I had 3 icons for this printer - copier, image writer and printer.

Now - after reinstalling I only have two icons ?

does this help explain what is happening?


  howard64 17:35 15 Dec 07

do you have the cd for the canon printer? it may be that the new part has altered it and you need to install different drivers for it.

  zaz 17:38 15 Dec 07

the printer is only 18 months old ......and I do still have the original installation cd which is what I have just used ........

why didnt the printer part reinstall? any ideas ;-)


  howard64 17:44 15 Dec 07

sometimes it is too clever by half and just uses what is already on the pc rather than take from the cd. A further thing to try might be to go to the Canon site and download the latest driver for that printer.

This thread is now locked and can not be replied to.

The Legend of Zelda Breath of the Wild review: Five hours with Zelda on the Nintendo Switch

1995-2015: How technology has changed the world in 20 years

How the painting-like animated sequences in A Monster Calls were created by Glassworks Barcelona

The 22 best Safari extensions | Best Safari plugins: Improve Apple's Safari web browser with these…