ie8 freezing

  awest3 12:08 PM 06 Mar 12


I'm using windows 7 and IE8. Sometimes when I'm browsing the spinning circle comes on and I do not get to the new page. If I use the back arrow and then the forward arrow the page comes up instantly.

Any ideas on what may be causing this..?

  birdface 12:21 PM 06 Mar 12

Go to command prompt and type in ipconfig /flushdns and press enter on your keyboard.It should tell you that the DNS Cache has been flushed.See if it makes any difference.

Also make sure compatibility mode is ticked under tools.

  john bunyan 12:26 PM 06 Mar 12

Have you tried IE9?

  awest3 12:51 PM 06 Mar 12

Hi Thanks for these. Yes I've tried IE9 but don't much care for it.

I'll try the flush..


  awest3 11:02 AM 11 Mar 12

Ttried the flush but its made no difference. Anything else I can try?

  awest3 12:43 PM 29 May 12

I'm now on IE9 but I till have the same issue. If I switch from one page to another I get the spinning circle, if I hit the back arrow then the forward arrow the page comes up instantly. Any further help welcomed as ever.

  Woolwell 14:21 PM 29 May 12

What is your download speed?

What add-ons, ad-blockers, anti-virus are your running?

How much RAM?

Have you cleared the browser cache (internet history)?

Have you tried a different browser eg Chrome of Firefox?

  birdface 15:39 PM 29 May 12

Is your flash and java programs up to date.if not remove the old versions and download the new versions.

Tools,Internet options.And click on restore advanced settings and see if that helps.

If not try pressing the reset button.You may loose your add-ons but it will reset Internet explorer to it's original state.

Try another browser like Woolwell say's.I use Firefox which I find much quicker than I/E

  awest3 16:38 PM 29 May 12

Download speed 2.5mb, ms essentils, dell inspiron 530s, 4 gb ram, I clear my internet history with CCleaner, also use malwarebytes, emisoft, superantispyware, Advanced system care, wise registry cleaner. twin 750gb disks, 3.2gz dual processor. I update software using 'update checker' from Hippo. Only happened since installing windows 7 - all up to date. not checked my addons so will disable them and test it out.

  Woolwell 20:07 PM 29 May 12

There are few things there that I wouldn't use - Advanced system care, wise registry cleaner and update checker. I wonder if some of your snags are caused by the registry cleaner, etc. CCleaner is relatively safe but I'm not sure about the others. I don't update drivers unless I have a problem. However do you have all of the Windows drivers and in particular is the graphics driver up to date. IE9 uses the gpu see IE9 GPU hardware acceleration

  birdface 23:15 PM 29 May 12

[Only happened since installing windows 7]

Check in Device manager to see if there are any yellow exclamation marks anywhere.

Sometimes an unsigned driver can give you problems like what you have.

Make sure Compatibility mode is ticked under Tools.


This thread is now locked and can not be replied to.

Best Cyber Monday deals 2015 live blog: Best UK Cyber Monday tech deals, sales, discounts & offers

1995-2015: How technology has changed the world in 20 years

Harry Potter's graphic designers showcase magical props & posters in new exhibition

Apple rumours & predictions 2016: What to expect from Apple in 2016