IE8 Don't laugh, Google has it always done this ?

  mooly 11:57 26 May 10
Locked

One of those daft questions that's bugging, and I am not sure if it has always done this.

Important info... I have my mouse set to single left click, which I prefer.

SO

Why do I have to do a very quick double left click to return to the google home page from leaving a website.

eg,
1. Go to Google home page.
2. Type BBC... which brings up pages of choices.
3. Enter a site (eg BBC) from list, navigating through the site with foward and back buttons at top left of toolbar.
4. Using the "back" button there is no problem until I reach the point where I should return back to Google.

At this point hovering the cursor over the back button shows googles address followed by "slash" and the site I have just been in, so it always keeps opening that particular site.
Have to do a smart double click to get back to Google.

Why ?

If I do the same from "Bing" there is no problem, the back button takes me right back to Bing home page with single clicks.

The clue of course is that when leaving a site and hovering the cursor over the "back" button it always shows google followed by the last site address, as where you are going to end up.

  gengiscant 12:02 26 May 10

I have had similar problems this morning, not being able to back button to the original Google page. Must be a Google problem.

  northumbria61 12:06 26 May 10

At the top left hand corner of your screen on Internet Explorer you will find (next to where you type in the URL) a blue "down-pointing" arrow which says "recent pages" - this will take you back to what you want.

  Audio~~Chip 12:06 26 May 10

I have also found this bug and looking into it at the moment. Its not IE.8 but google thing just seems to have started today. Spooky eh

If I manage to source more info then I will post back as you cannot fix google. I just tried and it sticks on the webpage not letting me go back

Google please fix this!

  northumbria61 12:07 26 May 10

I don't know if it is something Google have just added but I just recently discovered it having had the same problem.

  mooly 12:07 26 May 10

How strange... thought it was just me.
Thanks

  mooly 19:46 26 May 10

Even more strange... now it's OK.

I'll wait 'till tomorrow before giving it the "resolved" tick.

  Sea Urchin 21:02 26 May 10

It's not a Google thing - as it works perfectly normally in Firefox. And it works correctly in IE7. So I suspect that it's a Windows update for IE8 which has inadvertently altered the use of the back button, but only in Google. I had two different people phoning me this morning with this query.

  Audio~~Chip 22:25 26 May 10

Going into IE.8 Internet Options - Advanced - run the Restore and reset options close the browser open the browser clean out all history, autocomplete etc close IE then re-open ?

  Audio~~Chip 22:41 26 May 10

Google Problem now fixed apparently

This thread is now locked and can not be replied to.

How to get Windows 10 for free | How to install Windows 10: There is still a way to avoid paying…

1995-2015: How technology has changed the world in 20 years

Alex Chinneck’s giant ice cube Christmas tree at Kings Cross

Apple rumours & predictions 2017: The iPhone 8, new iPads, and everything else you should expect fr7…