IE7 very slow on start up & sporadically later on

  rickus 18:44 18 Feb 07
Locked

I have been running IE7 for a few months. Initially it ran fine but things seem to have slowed up in the last couple of weeks:

When I open IE7 it can now take several minutes before it accesses anything. Although Outlook Express also seems to be taking longer to get going it is able to do things even when IE7 is still stuck.

After this delay the first time I open it, it seems to run OK but then every so often seems to 'pause' again.

I see there are a lot of threads here about IE7 performance but the ones I have looked at do not seem to explain why it should have run OK at first and now deteriorated. Before I give you a lot of other detail about my PC set-up (e.g. I wonder whether Avant is playing a part in this) are there some quick tweaks I could try to see if they help? (I have updated my Spyware and Adware software and this does not seem to have helped much)

  chub_tor 19:09 18 Feb 07

Have you applied this Microsoft patch click here it is also referred to in this article click here

  rickus 19:16 18 Feb 07

Thanks chub_tor

I actually disabled the phishing filter a few days ago. It may have made a minor improvement, but not stopped the problem - I have suspicions that it is still doing something in the background.

Might it be worth applying the patch anyway, even with the phishing filter turned off?

  chub_tor 19:24 18 Feb 07

As it is a patch issued by Microsoft I would be inclined to apply it. I certainly noticed a difference in page loading speed but I do still have the phishing filter on.

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

The updated 'Corel Painter inside Photoshop' plugin ParticleShop offers new brushes

New MacBook Pro 2017 release date, UK price and tech specs: Kaby Lake MacBook Pro to launch in…