IDE Channel DMA Problems

  SimpleStevie 15:09 09 Apr 05

Hi guys,

I have recently purchased a new OEM NEC-3520 DVD Writer to replace my old CD writer. I am having a few problems getting it working properly, supposedly all because of the DMA mode the IDE channel is set to. Currently it is Multi-Word DMA Mode 2 where apparantly it should be DMA Mode 2.

There doesn't seem to be an abvious way to change it to DMA Mode 2, in device manager the drop down list is greyed out. One person reckons I just need a new 80 pin IDE cable to replace the 40 pin one I have, another says I need a new motherboard, another says I just need to install the original Microsoft IDE drivers.

Can anyone shes any light onto this, its really starting to annoy me??


  LastChip 15:30 09 Apr 05

and how olds the machine? Do you know which motherboard you have?

  SimpleStevie 15:45 09 Apr 05

I Have a Jetway V333u motherboard bought on 31st November 2002, could this be the problem?

  SimpleStevie 15:47 09 Apr 05

Running XP Pro SP2

  LastChip 16:30 09 Apr 05

Right click My Computer; Properties; Hardware; Device Manager; and go to View; Resources by type. Expand DMA and right click Direct Memory Access Controller; Properties; Resources. Does this have a DMA number (might be 04) and listed as no conflicts.

If this is OK, have you ran the Troubleshooter from your NEC drive within Device Manager?

To do this, in Device Manager, select View; Devices by type and expand the DVD/CD ROM Drives. Right Click your NEC drive; Properties; and click on the Troubleshoot button.

As an aside, you should be using this drive with an 80 strand data cable, but whether that would cause your problem, I'm not sure.

  SimpleStevie 20:41 09 Apr 05

Went out and bought myself an 80 strand ide cable to see if that made a difference, it didn't.

Gone through the steps you siggested LastChip and there were no conflicts and the troubleshooter didnt help.

Also updated my BIOS to the latest version and still saying Multi-Word DMA Mode 2, got any other ideas??

  Fruit Bat /\0/\ 21:00 09 Apr 05

Re-enable DMA using the Registry Editor

Run REGEDIT. Go to the following key:


It has subkeys like 0000, 0001, 0002, etc. Normally 0001 is the primary IDE channel, 0002 the secondary, but other numbers can occur under certain circumstances. Check the DriverDesc value to see which one it is.

Delete MasterIdDataChecksum or SlaveIdDataChecksum, depending on whether the device in question is attached as master or slave, but it can't actually hurt to delete both. Reboot. The drive DMA capabilities will be redetected.

Open Device Manager again and check whether the device is now actually using DMA mode. If so, congratulations, you've made it (at least until the next time Windows disables DMA).

Alternative Method—Uninstalling the Port
1. Uninstall the secondary IDE port
To do that, open Device Manager as follows. Right-click on My Computer, select Properties, click on the Hardware tag, click on the Device Manager button, click on the plus sign to the left of IDE ATA/ATAPI Controller, right-click on Secondary IDE Channel, click on Uninstall. Deactivating is not enough.

Reboot to make the changes active and permanent.

After booting Windows will automatically reinstall the IDE channel and the DVD (or CD) drive. This Plug-n-Play process can take a little while, so give it a minute after the boot process finishes.

2. Reactivate DMA
But this is not enough, because unfortunately Windows does not automatically activate DMA on a DVD or CD drive. You have to tell Windows to try to use DMA first.

For that, go to Device Manager again. Right-click on My Computer, select Properties, click on the Hardware tag, click on the Device Manager button, click on the plus sign to the left of IDE ATA/ATAPI Controller, double-click on the secondary IDE channel, click on Extended Settings and change the relevant setting from PIO only to DMA when available.

On Windows NT and 2000 you now have to reboot a second time, but Windows XP applies the change instantly. Then you can go to the same place in Device Manager again and check whether the device is now actually using DMA mode. If so, all is well.

3. Driver is not intended for this platform
If you keep getting the following error message:

There is a problem installing this hardware.

IDE channel

An error occurred during the installation of the device. Driver is not intended for this platform.

then the way out is to rename C:\WINDOWS\system32\drivers\atapi.sys (or a similar path on your computer) to something like atapi.old.

If that's not possible, you can try it from the repair console (boot from the Windows install CD and select the repair console).

If Windows always automatically recreates atapi.sys, you can try renaming it in safe mode or from a command line window or you can try to rename or remove it in the driver cache as well.

Desensitize Your Computer's IDE Channels
There's a bit more to it. The following article offers a way to reduce the incidence of this problem, although it still doesn't solve it altogether.

IDE ATA and ATAPI Disks Use PIO Mode After Multiple Time-Out or CRC Errors Occur
click here

Do read this article because it contains a useful long-term workaround. But you have to go through the procedure described here to re-enable DMA first. Assuming you've done that, insert the ResetErrorCountersOnSuccess registry values mentioned in this article into both the primary and the secondary IDE port registry keys as described.

  LastChip 21:01 09 Apr 05

Do you have a second device connected on the same IDE channel?

  SimpleStevie 00:26 10 Apr 05

Gone through the steps you suggested Fruit Bat but to no avail.

Yes I do have a second device connected on the same IDE channel, just a bog standard 16x DVD reader, could this be causing the problem?

  LastChip 09:29 10 Apr 05

Temporarily disconnect it - data and power cable and see if that resolves the issue.

This thread is now locked and can not be replied to.

How to watch Windows Event live stream, live blog | Microsoft event live stream: Watch Microsoft…

1995-2015: How technology has changed the world in 20 years

This amazing app turns your iPad Pro into a Cintiq

iPhone 7 Plus review: A superb big-screen phablet, but the price tag's enormous | iPhone 7 Plus…