IDE !!! - can I fix it myself?

  mco 17:28 14 Dec 03
Locked

Please advise in a simple non -technical way: this happened to me in the summer and I had to take my computer back to the shop: working fine with all latest stuff then one day (today) find I can't use my cd drive and on device manager my IDE's have exclamation marks - something about cod 10 and something about MS DOS compatibility. this means nothing other than that something is wrong cos that's what happened before. I thought maybe I'd either installed or downloaded something to corrupt them - so I've deleted into recycle bin all recent installations/downloads. still same problem. Windows tells me drivers are latest possible ones - is there a way I can get my !! s to go or do I have to take it back to the shop - AGAIN? What could I have done wrong?

  woodchip 17:30 14 Dec 03

Remove the drive in Device Manager and restart comp

  woodchip 17:31 14 Dec 03

PS the one with the mark

  Big Elf 17:32 14 Dec 03

I've had this but for the life of me can't remember how I fixed it. There is an MS article about it at click here

  Big Elf 17:33 14 Dec 03

I think I may have fixed my problem by uninstalling the IDE controllers. If that was the case you may need your Windows installation disk to fix it.

  Forum Editor 17:56 14 Dec 03

uninstalling and reinstalling your IDE controllers will have no effect. The compatibility mode is being forced because the protected mode driver isn't being properly initialised, and that usually means that a value (NOIDE) has been placed in the registry to stop Windows from trying to initialise the protected mode driver.

The cure is a registry edit, and if you feel up to that you can almost certainly fix the problem:

1. Always back up your registry before editing it in any way.

2. Click Start, then select Run, and type regedit. Now click on file and select 'Export'. Save your registry file to your desktop and you're ready to begin.

3. Navigate down to this key:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\IOS

4. You should see a value named "NoIDE". Right click on the name, select Delete from the context menu, close regedit and reboot.

5. Go back to the registry and search for BAD_IDE (You can Search the registry by pressing F3 while working in the registry editor.) Delete any BAD_IDE values you find.


Your computer should now be OK but make sure all is well before deleting the regisry back up file from your desktop.

  mco 20:37 14 Dec 03

forum editor I followed your instructions to the letter - now my CD drive's reappeared; I've got +++ against my IDE's and you've no idea how grateful I am! Thankyou so much! Just one question by the way: When I got to your number 5 and got to FIND and typed BAD_IDE(values/keys/data all ticked) only one thing came up saying those exact words BAD_IDE but half a dozen other things came up also, including one saying BAD primary. I only deleted the one saying specifically BAD_IDE but should I have deleted the others too - or might that have been a dangerous thing?

  Big Elf 10:37 15 Dec 03

I don't know but FE might.

This thread is now locked and can not be replied to.

Best phone camera 2016/2017: Galaxy S7 vs iPhone 7 vs Google Pixel vs HTC 10 Evo vs OnePlus 3T vs…

1995-2015: How technology has changed the world in 20 years

Best Christmas Agency Projects of 2016

Super Mario Run preview | Hands-on first impressions of Super Mario Run: Mario's iPhone & iPad…