IDE cable not detected

  martjc 11:50 29 Oct 04

A new problem arose. When I boot up I get a message before Windows XP starts. "Primary IDE channel. No 80 conductor cable detected." Things I've done: 1. swapped the cable with a new one. 2. used a shorter cable. 3. checked that all the pins are straight. Strange thing is that the machine works fine apart from: On IDE 2 I have CDRW drive and DVD drive. These do not detect when a new disk is put in. If I click on them in Explorer I get "Please put a disk in drive x:"

I have tried these drives every way round with the same result: If a disk is in when I boot up it's fine. Problem is when I put in a different disk while the machine is on.

I'm sure these two problems are related, but HOW?

Any ideas??

  JonnyTub 12:10 29 Oct 04

if the ide is listed in device manager, right click on it and select uninstall, reboot and allow windows to automatically reinstall the driver, should the old have become corrupt.

  martjc 12:14 29 Oct 04

That was one of the first things I did, thinking 'corruption'. No Go.

  JonnyTub 12:18 29 Oct 04

have you tried setting the bios to factory defaults?

  buscrew 12:21 29 Oct 04

Don't know if this will help, but have you replaced the 80 wire cable with a 40 wire cable, which you maybe don't need.

  martjc 12:26 29 Oct 04

But this is getting stupid now. I deleted the ide settings again as you first suggested and it seemed to work! Guess it's a case of 'Computers always work perfectly - sometimes.' Thanks for your help.


  JonnyTub 12:28 29 Oct 04

ide drivers.. don't you just love em :0)

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

This abstract video touches on division in our technologic world

Best alternatives to iTunes for Mac | Best music players for macOS: Free your music from the…