ICS & simple network - what have I missed?

  Granger 16:57 14 May 03
Locked

WinXPPro desktop with DSL modem attached and Norton Internet Security. New laptop connected by crossover cable. Ran network setup wizard on both, and eventually got it to work when I put the current IP address of the laptop in the trusted zone of NIS. I could share the external connection as well as files and folders.

Today plugged the laptop back in. Nothing. I've tried everything I can understand. I've run through a MS knowledgebase article on setting static IP clients for ICS (because I thought a dynamic IP address of the laptop might be the problem). That didn't work so I've reversed that process. I've tried "repairing" the connections, but I get an error saying it failed at renewing the IP address. If I disable NIS I seem to be able to share files and folders but not the broadband connection. Nothing will seem to make the ICS work.

I've searched for relevant past discussions but to be honest I struggle to understand whether some of them are relevant.

Could someone walk me through?

  AndySD 17:12 14 May 03

Can you tell us the relevant Operating systems?

  Granger 17:17 14 May 03

Both units are on WinXP Pro SP1. The hardware is definitely fine. I've just gone through the short walkthrough on PC911, but I don't think the answer's there.

  AndySD 17:36 14 May 03

Two methods I have found to work quickly/simply with this.. on the notebook

1. Go Start/Conntrol Panel/System and use the Networking Wizard there.

2.Go Start/Conntrol Panel/System/Device Manager and remove the network connection reboot and let windows restart the network wizard clean.

  Granger 18:03 14 May 03

I've wasted the whole day on this! Andy, I tried what you said but this doesn't seem to have been the answer.

Please help more, I'm desperate! Should I specify IP addresses, or leave them automatic?

  AndySD 18:12 14 May 03

Go to the pc and in the network connections folder and right click on the internet connection and make sure its set for ics and the windows xp firewall is disabled

Go to each PC and Go Start/Accessories/Command Prompt and type in

ipconfig /all

check that they are both on the same Subnet (255.255.255.0) and that the pc is 192.168.0.1

on the laptop make sure the default gateway is 192.168.0.1

If it is this way and both notebook and pc have a different name and are in the same workgroup... then its most likely to be the firewall.

  Granger 18:39 14 May 03

Before I tell you about the IP addresses - I can access the laptop from the PC but not the other way round.

They are both on the same subnet. Last time I looked the IP address for each was something like 192.168.. but now both are on variations of
"Autoconfiguration IP address: 169.254..".

The laptop also says IP routing not enabled - is that right?

BT says I have a fixed IP address for the broadband connection - is this relevant? In IPCONFIG, under the heading of the PPP broadband, there are IP address, subnet mask and default gateway. These don't agree with the values given under the heading of ETHERNET ADAPTER in IPCONFIG. It also says DHCP not enabled for the broadband.

I have specified the workgroup name for both units.

  Granger 18:46 14 May 03

the firewall is disabled while I'm trying to figure this out.

  AndySD 18:54 14 May 03

The BT connection you can leave alone.

Set the ip address on the pc to 192.168.0.1 and the laptop to 192.168.0.9

I am afraid I have to go now to take my wife out to dinner will be back in the morning. Hopefully someone else will carry on from here.

  Granger 20:14 14 May 03

I set the PC to 192.168.0.1, the laptop to 192.168.0.9, and both have subnets of 255.255.255.0. I also did the rest of what the MS article asked:

Add a valid ICS private IP address to the client.
Configure the default gateway to be 192.168.0.1.
Configure the preferred DNS server to be 192.168.0.1.
Add MSHOME.NET as the DNS suffix on the client.
Add an entry for the client to the Hosts file on the Windows XP-based ICS host, using client_name.MSHOME.NET as the name.

I can exchange data between the computers again, and they can ping each other. The only trouble now is I still can't seem to use the PC's broadband connection. I saw somewhere that I need two NICs in the PC to achieve this, but surely not because I shared the connection successfully yesterday? I'm not imagining things - I used the connection to update the laptop's antivirus files. The firewall is still disabled.

  AndySD 07:38 15 May 03

Ok so the network is now working.

Go to the pc and in the Command Prompt type in

tracert microsoft.com

and hit enter..... does it say anything

Now type in

ipconfig /all

and hit enter... what does it say about the non network connection.

(ps you dont need two NICS)

This thread is now locked and can not be replied to.

iPhone 7 review: a range of small updates add up to an excellent phone

1995-2015: How technology has changed the world in 20 years

How New York’s Stylin’ Seniors became a golden social media campaign

23 Apple Watch tips & secret features: Master your Apple Watch, Apple Watch Series 1 or Apple…