IBM / lenovo Thinkpad Keyboard Driver problem

  Job CF 16:36 27 May 07
Locked

I have an IBM/lenovo Thinkpad R51 Series 2887 NQ7, about 18 months old. Bought it from an IBM dealer when abroad. He installed Win XP SP2. I have never been able use some of the keys correctly. Last year, IBM online support told me to contact my local IBM dealers in Brighton, UK. The dealer do not want to know because I did not buy from them.

I put up with this but now need to use 'backward slash' key to work in the DOS box.

Can any of you help?!

Device Manager state:
Standard 101/102-Key or Microsoft Natural PS/2 Keyboard
Driver Provider: Microsoft
Driver Date: 01-07-2001
Ver 5.1.2600.2180

Where can I get the correct driver?

  Fruit Bat /\0/\ 16:47 27 May 07

If you hit the backslash key do you get something else instead?

You may just need to set the keyboard to English UK.

Start settings - control panel - regional and language settings - put EVerything to English UK Apply and then reboot the laptop for the changes to take effect.

  Job CF 17:08 27 May 07

Did that last year. Checked again now and all is as it should be in "regional and language settings". No £ key on my keyboard but I get that by pressing the '#' above '3'
When I hit the backslash key I get #
Forward hash / works okay.

Being a laptop the built-in keyboard of the Thinkpad do not have 101/102-Keys. Start>Settings>Contol Panel>Keyboard do not allow me to change it either.

  Fruit Bat /\0/\ 17:48 27 May 07

So your keyboard is laidout in the American style.

Set the regional languages and settings to English US and the \ should work.

All drivers click here

  Job CF 20:40 27 May 07

In 'Regional and Language Options' under the tab 'Regional Options' chose 'English (United States);

under the tab 'Advanced' chose 'English (United States);
re-booted; no change.

Went back to ckeck and noticed the tab 'Languages'. Clicked 'Details' chose 'English (United States)- United States-International

\ / and all other keys works now exactly as shown on the keyboard.

We have a RESULT :-)

Many thanks Fruit Bat

Cheers!

Lost my Pound symbol though.

Tried various combinations of:
Changed back to 'English (United Kindom) in the tab 'Regional Options'. No change.
Changed back to 'English (United Kindom) in the tab 'Advanced' . No change.
Went back to the tab 'Languages', Details, tried various combinations of 'English (United Kindom) and US. Encountered new problems such as 1 2 3 appearing instead of j, k l. Corrected using Ctrl + Shift + NumLk

Can live without the Pound Symbol for the time being. So set everything to US for now.

  Job CF 21:21 28 May 07

£ symbol problem also solved :-)
To get Pound Symbol £ when pressing # did this:

under 'Languages tab' > Details> Settings tab, chose 'English (United Kindom)-US'

Click 'key settings' and view 'Action' given to 'Switch between input languages'.

For a few seconds press LeftAlt+Shift to get: # to £ and \ to #
Same action to change back

Left the setting below as:

under tab 'Regional Options' > chose 'English (United States)'

under tab 'Advanced' > chose 'English (United States)'

Many thanks 'Fruit Bat' for your hep and guidance in solving this problem I had since buying this laptop over 18 month ago.

CHEERS!

  Job CF 21:23 28 May 07

Problem Resolved :-)

This thread is now locked and can not be replied to.

Intel Coffee Lake 8th-gen Core processors release date rumours

1995-2015: How technology has changed the world in 20 years

Apple MacBook Pro with Touch Bar review

Best iPhone games 2017 | Best iPad games 2017: 162 fantastic iOS games that you need to play right…