How to set Photoshop as default Photo prog

A friend has asked me how to set Photoshop as the default program for his pictures I cannot remember what I did. He keeps getting Nero opening when he clicks on a photo icon

  Eric10 15:30 20 Oct 05

For XP, right-click the photo's icon and choose 'Open With' from the menu then 'Choose Program' at the bottom. Select Photshop from the list or browse to it and tick the box labelled 'Always use the selected program to open this kind of file' before clicking OK.

  hssutton 22:04 20 Oct 05

You don't say which version of photoshop, but what Eric10 says will probably solve the problem.

However this is a known problem with later versions of PS, and can be cured, but means editing the registry, so beware.

HKEY_CLASSES_ROOTApplicationsPhotoshop.exeshellopencommand(Default)

For some reason, sometimes Windows XP creates this key the first time without "%1" at the end. Delete the (Default) entry, go to Windows Explorer, select a file type you want to open in Photoshop, right click, go to Open With, select Choose Program, click Browse (Photoshop won't be in the list after deleting the registry key), select your Photoshop executable, and make sure "Always use..." is checked.

Thanks to Eric10 and hssutton, my friend tells me he has solved the problem, I will remember the solution myself

This thread is now locked and can not be replied to.

iPhone 7 review: a range of small updates add up to an excellent phone

1995-2015: How technology has changed the world in 20 years

How New York’s Stylin’ Seniors became a golden social media campaign

23 Apple Watch tips & secret features: Master your Apple Watch, Apple Watch Series 1 or Apple…