How do I set up a network to share printers?

  flick 17:58 06 Nov 03
Locked

We have 3 computers which connect via a router and ADSL modem to the internet. The laptop (XP Home) and a PC (win2K) connect wirelessly and the other PC (XP Pro) via ethernet. Internet works very well on all 3 machines.
I would like to share the printers. There is an HP laserjet attached to the Win2K PC and a Lexmark X75 attached to the XP Pro PC.

XP Networking wizard does not seem to do anything except throw up errors and in any case is not supported on Win2K, so I'm not sure if I have a network set up.

Can it be done manually?

I'd quite like to share some files as well; is the principle the same?

Help and/or pointers to useful websites would be much appreciated.

  wiznyme 19:05 06 Nov 03

Go to start/ printers, click on add printer, select network printer & click next, click on browse & next, select the printers, click on next then finish.

  flick 22:02 06 Nov 03

I had tried that but neither printer appeared in the browse list. Since the network wizard wasn't working as expected I assumed that a network has not been established. Can this be done manually?

  Sam Witch 23:44 06 Nov 03

can you browse your network, have you set up shares on the printer, you may have to install the printer driver(s)on all the machines(may means probably). try not to share the main drive. Plus anyone will tell you that opening file shares is quite dangerous unless you are protected firewall + passwords.

  Sam Witch 00:02 07 Nov 03

I fogot to add the link as requested.

click here has loads of info.

  flick 00:33 07 Nov 03

Thanks for the suggestions Sam. I have set up printer sharing on the main computer - the one with the printer attached. I haven't found the printer when browsing the 'network'. Do I need to install the drivers on the other computers first?

I'm still not convinced I really have a network since the wizard did not run smoothly. For example: when I tried to access the network from the main computer (the one I ran the wizard on) I got an error message - 'HOME is not accessible. You may not have permission to use this network resource ....
The list of servers for this workgroup is not currently available.

This suggests that the network may have been partially set up (I called it HOME) but not completely. This is why I asked if it possible to set it up manually.

The router has an inbuilt firewall which I am assuming will protect the network.

I will read through your link for further ideas, for which many thanks.

  Sam Witch 08:58 07 Nov 03

It appears you may have not set up a network. Did you use the wizard for internet connection, there is another for network connection. Check the network settings in the control panel of each machine to make them the same. You need to make sure that whatever firewall(s) you have allow the other pc's to talk to each other.
manual setup can be done, You have to identify each pc and then get the others to connect. make sure each has a unique name on the same network name.
Check the IP addresses for each machine open a DOS window and type ipconfig /all - the result will give you the IP address for that machine then using that address 'ping'in a DOS window from the other machines. If you get a dos connection you know they are connecting it is then a matter of correctly specifing network settings, your router help will also assist with things like dynamic IP addressing.

In my case the other pc auto-installed the printer driver when I found it and tried to print from it.

Firewalls on routers are like a first wall of defence for outside attacks you should also monitor each PC with another firewall because if you are compromised you wont know it, eg before you setup the network.

  recap 12:18 07 Nov 03

I think the problem lies in that fact that the printers have not got network cards in them. If this is the case load the printer software on all machines, you should then be albe to network them.

  wiznyme 18:37 07 Nov 03

I you can access the internet via all 3 pc's then your network is set up ok, problem is most likely with permissions.

On the computer with the printer attached go to start, printers, right click on the printer icon and select properties, click on the sharing tab and make sure the option to share the printer is selected.

  flick 22:57 07 Nov 03

In response to the last three posts: The software I used to set up the internet connection came with the router and that has been working fine for several months.
I used the XP wizard to set up the network for file and printer sharing but this hasn't worked and I have enabled printer sharing on the relevant machines. Interestingly the win2k computer does now show the other two in Networks but cannot access the printer on the one I ran the wizard on. This may be for lack of drivers.

My plan now is to restore the 'wizard' computer to last week sometime, load the drivers on the laptop and win2k and enable printer sharing. If this has no effect then my last resort is to use the software that came with the wireless adapter (Belkin) even though it says it's compatible with w9x and win2k . It doesn't say it's not compatible with XP.

Many thanks for all the suggestions, I'll let you know I get on.

This thread is now locked and can not be replied to.

How to get Windows 10 for free | How to install Windows 10: There is still a way to avoid paying…

1995-2015: How technology has changed the world in 20 years

Alex Chinneck’s giant ice cube Christmas tree at Kings Cross

Apple rumours & predictions 2017: The iPhone 8, new iPads, and everything else you should expect fr7…