How do I set up Intel WiDi Samsung RV520-07 uk Laptop?

  OLDJACK 22 Oct 13
Locked

I've updated all the drivers relating to Intel including the N130 adapter and the HD3000 video. When I try to install the WiDi from Intel I get an error " incorrect platform" Any ideas? What else do you need to know?

Windows 7 pro 64 Intel proset wireless installed on N130

  OLDJACK 22 Oct 13

Adding to my above question. I've updated all the intel drivers BUT it all comes to a halt because of a later update to the wireless adapter 130N when I find I can't update from driver 15.9.0.5 to 16.1.1 because I can't uninstall the old driver. There seems to be a number of people with this problem and Intel are non too helpful.

  Secret-Squirrel 22 Oct 13

Jack, Intel WiDi requires a compatible motherboard and Intel CPU. Not all laptops meet those requirements. Did the specifications for your Samsung say it's WiDi equipped?

  OLDJACK 24 Oct 13

Thank you Squirrel.I know that the cpu and the N130 adapter are compatible.The USA version of the Rv520 was WiDi enabled but for some reason the UK version wasn't. I'm seeking answers from Samsung to see if it is possible. There seems to be a few problems with Intel PROSet/Wireless WiFi updating I can update to 15.2 level but beyond that it doesn't seem to accept that the previous version has been uninstalled so won't update to 15.6...15.8...or the latest 16.1. here seems to be lots of posts with this problem.

Advertisement

This thread is now locked and can not be replied to.

Should I upgrade to Windows 10? 8 reasons why you should upgrade to Windows 10... and 2 why you…

We are being sold the ability to spend money we don't have. And we love it

IKinema aims to banish droopy shoulders and wonky spines in animated CG characters

How to use Apple Music in the UK: Complete guide to Apple Music's features

We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message