How do I enable DMA?

  wetterfugal © 19:35 24 Jul 05

That's it,How do I enable DMA on my hard drives?
I have two internal and one external.

Maxtor 6L060J3, 6Y080L0 I am not sure of the external Maxtor drive

  De Marcus™ 19:37 24 Jul 05

In device manager right click on each of the ide channels in turn and on then on the advanced tab enable DMA from there.

  wobblymike 19:39 24 Jul 05

Go into control panel - admin tools - computer management - device manager
In the right hand pane open up IDE ATA/ATAPI Controllers double click Primary IDE Channel - select the advamced settings tab and select away.

  Fruit Bat /\0/\ 20:42 24 Jul 05

Re-enable DMA using the Registry Editor

Run REGEDIT. Go to the following key:


It has subkeys like 0000, 0001, 0002, etc. Normally 0001 is the primary IDE channel, 0002 the secondary, but other numbers can occur under certain circumstances. Check the DriverDesc value to see which one it is.

Delete MasterIdDataChecksum or SlaveIdDataChecksum, depending on whether the device in question is attached as master or slave, but it can't actually hurt to delete both. Reboot. The drive DMA capabilities will be redetected.

Open Device Manager again and check whether the device is now actually using DMA mode. If so, congratulations, you've made it (at least until the next time Windows disables DMA).

Alternative Method—Uninstalling the Port
1. Uninstall the secondary IDE port
To do that, open Device Manager as follows. Right-click on My Computer, select Properties, click on the Hardware tag, click on the Device Manager button, click on the plus sign to the left of IDE ATA/ATAPI Controller, right-click on Secondary IDE Channel, click on Uninstall. Deactivating is not enough.

Reboot to make the changes active and permanent.

After booting Windows will automatically reinstall the IDE channel and the DVD (or CD) drive. This Plug-n-Play process can take a little while, so give it a minute after the boot process finishes.

2. Reactivate DMA
But this is not enough, because unfortunately Windows does not automatically activate DMA on a DVD or CD drive. You have to tell Windows to try to use DMA first.

For that, go to Device Manager again. Right-click on My Computer, select Properties, click on the Hardware tag, click on the Device Manager button, click on the plus sign to the left of IDE ATA/ATAPI Controller, double-click on the secondary IDE channel, click on Extended Settings and change the relevant setting from PIO only to DMA when available.

On Windows NT and 2000 you now have to reboot a second time, but Windows XP applies the change instantly. Then you can go to the same place in Device Manager again and check whether the device is now actually using DMA mode. If so, all is well.

3. Driver is not intended for this platform
If you keep getting the following error message:

There is a problem installing this hardware.

IDE channel

An error occurred during the installation of the device. Driver is not intended for this platform.

then the way out is to rename C:\WINDOWS\system32\drivers\atapi.sys (or a similar path on your computer) to something like atapi.old.

If that's not possible, you can try it from the repair console (boot from the Windows install CD and select the repair console).

If Windows always automatically recreates atapi.sys, you can try renaming it in safe mode or from a command line window or you can try to rename or remove it in the driver cache as well.

Desensitize Your Computer's IDE Channels
There's a bit more to it. The following article offers a way to reduce the incidence of this problem, although it still doesn't solve it altogether.

IDE ATA and ATAPI Disks Use PIO Mode After Multiple Time-Out or CRC Errors Occur
click here

Do read this article because it contains a useful long-term workaround. But you have to go through the procedure described here to re-enable DMA first. Assuming you've done that, insert the ResetErrorCountersOnSuccess registry values mentioned in this article into both the primary and the secondary IDE port registry keys as described.

Unfortunately this is only a half solution, because when you enter an unreadable DVD, you will get 6 errors in a row, and the IDE channel will revert to PIO mode, but at least when you pull out the DVD in time and then insert a good one, the error counter will be reset and it will at least be a bit more difficult for Windows to hobble your IDE drive.

  wetterfugal © 22:48 24 Jul 05

Thanks for the info:

De Marcus™ :- Tried it but I do not get the advanced tab. The IDE Channels dont show as sutch, thereseems to be a step missing.

wobblymike :- Tried it, IDE ATA/ATAPI ok Primary IDE ok but no Advaced tab, double click brings up a panel showing the two Maxtor drives Both had 'let bios set transfer mode' box checked. This greyed out the transfer mode window which contained "Ultra DMA 6-Ultra 133" wich I remember was in the drive specs when I chose the drives.

I unchecked the box and the tranfer window became live. there was a dropdown listing other DMA modes but I left it at this one.

There is a speed check button which gave me :-

Disc 1 - Burst speed = 1.6MBs
Sustained = 800KBs

Disc 2 - Burst speed = 2.3MBs
Sustained = 11MBs

I am not sure what this is telling me.
I will give it a try and get back with my results in a couple of days. It will take me some time to digest Fruit Bat /\0\/'s reply.

I should have said that I was using WinXP pro which may account for the difference in device manager tabs.

  De Marcus™ 22:52 24 Jul 05

Xp pro is what I use and there should definitely be an advanced tab there. Something amiss here, are you expanding the entry and right clicking on a specific ide channel, i.e. primary ide, or secondary?

  De Marcus™ 22:55 24 Jul 05

Also click here as the advanced settings tab should definitely be there.

  Stuartli 22:59 24 Jul 05

Clicking on the Primary and Secondary IDE Channels in Device Manager to highlight each one and selecting Properties should enable you to use the Advanced tab where the DMA settings can be changed/enabled.

No "Extended Settings" tab on my XP Pro Device Manager configurations.

  woodchip 23:00 24 Jul 05

It's under IDE controller

  o44wen 23:02 24 Jul 05


I have Y!Mail set as my default mail client and when I click on it, it opens in IE however my default browser is FireFox. Does anyone have any idea how to change Y!Mail to open in Firefox instead?

  o44wen 23:02 24 Jul 05

wrong place to post this

This thread is now locked and can not be replied to.

Nintendo Switch (Nintendo NX) release date, price, specs and preview trailer: Codename NX console…

1995-2015: How technology has changed the world in 20 years

8 things designers (and brands) need to know about the modern woman

How to speed up a slow Mac: 19 great tips to make an iMac, MacBook or Mac mini run faster | Speed…