How to display proper file type in Explorer

  stlucia 07:39 27 Sep 10

When I view details of my files using Windows Explorer (Windows XP), all my graphics files are shown as being "CorelPHOTO-PAINT 4.0 Picture" irrespective of their actual origin.

How can I make Explorer display the proper file extension, such as .bmp .jpg etc. instead?

  gengiscant 08:11 27 Sep 10
  mgmcc 08:49 27 Sep 10

Files will normally show the icon of the program which is set as the default for opening that type of file. If you want to change their icon, set a different graphics program as the default with which to open them. The files' origin is immaterial.

  stlucia 11:17 27 Sep 10

Thanks gengiscant, that's done the job.

mgmcc, now that I've got the file extensions displayed, I'm not too fussed about the fact that they're incorrectly being shown as all the same "Type". CorelDraw presumably registered itself as the default graphics editor when I installed it. Since my graphics files are all different sources, how can I specify that NO program is the default graphics editor?

  lotvic 11:31 27 Sep 10

You can change the default program to open different file types through:
My Documents > Tools > Folder Options > File Types

I don't think you can set it to 'none' or 'always ask' (but I might be wrong)

  Ian in Northampton 11:55 27 Sep 10

stlucia: the issue becomes, when you go to Windows Explorer and double click on the file you want to edit, what would you prefer it to open with? The associations are there purely to make that process simpler. I guess the alternative, rather than double click, is to right click and then choose from the list of image editors you have installed.

lotvic: I think you're right, you can't choose 'none' - but I assume if you uncheck the box that says 'always open files of this type with this program' will then cause the drop down program list to appear when you double click on the file.

  Ian in Northampton 11:57 27 Sep 10

Thinking about it, I can perhaps see where stlucia is coming from. If I just want to do a basic crop, rotate or resize, then I'd probably want to use IrfanView, which is fast and light. But if I wanted to open that same image and do something more complex with it, then I'd want it to open with e.g. Photoshop.

  lotvic 13:27 27 Sep 10

Bearing in mind Ian in Northampton's info, then maybe just righclick on the pic file and choose from 'Open with' menu.

  stlucia 19:21 27 Sep 10

Seems like I'm simply stuck in my (old) ways: I don't normally browse through my files and then double-click on the one I want to run or view -- I usually start an application and then open/place/import files into the application. And I like to know what type of file it is.

Thanks for all your input.

  stlucia 10:46 04 Oct 10

I clicked on resolved because my file listings are now showing the correct file extensions.

But now I've just noticed I've got another similar problem since I made that change -- the files are no longer listed in alphabetical order. When using Windows Explorer I can change the order back to alphabetical by clicking on the appropriate header bar. But my problem now is that when I go to open the files from another application (e.g. Irfanview, CorelDraw, Pagemaker) the files are all listed in date order where previously they used to be in alphabetical order, just as in Explorer.

Any ideas, please?

  gizzyx 12:43 04 Oct 10

In the explorer window,just click on the heading "Name".Toggles between a-z or z-a.

This thread is now locked and can not be replied to.

Huawei P10 review

1995-2015: How technology has changed the world in 20 years

An overview: What leading creative agencies are doing to improve diversity

New iPad, iPhone SE & Red iPhone 7 on sale now