Homeplugs Failing to support Internet Connection

  Callum-1623688 19:41 21 Nov 10
Locked

I went and bought a pair of 85MBPS Powerline HomePlug Ethernet Adapters to have a decent connection.

The problem is that once I got the devices connected to the router, the mains and each other. They don't work. Oh I've connected the devices together just fine. They're plugged in and the devices tell me they're reading each other and that there is a stable connection between the two of them. The only issue is that no Internet Connection is being transferred and I have no idea how to make this happen, what do I do to troubleshoot this usse? What should I check for problems? Is there anything I can do with the router, to see if it is denying them internet access basically how do I make them work if they are not already?

  mgmcc 20:23 21 Nov 10

The first thing I'd check is whether the computer at the remote end of the Homeplug network is getting its correct IP address from the Router. Run IPCONFIG /ALL in a Command Prompt window and see what its IP address is.

Go to “Start > Run”, type...

cmd.exe /k ipconfig /all

...and click OK.

  Callum-1623688 20:59 21 Nov 10

"The first thing I'd check is whether the computer at the remote end of the Homeplug network is getting its correct IP address from the Router. Run IPCONFIG /ALL in a Command Prompt window and see what its IP address is.

Go to “Start > Run”, type...

cmd.exe /k ipconfig /all"

I did this and lots of stuff came up. Only I'm not entirely sure what I am looking for. What am I tryign to find after running the ipconfig/all that will show whether things are as they should be or not?

  mgmcc 22:57 21 Nov 10

Routers used in a home network most commonly allocate IP addresses that start with "192.168".

If the IP address for your network adapter starts with "169.254", then the PC has been unable to get an address from the router and Windows has defaulted to allocating the 169.254 address. This won't let you access either the router or the internet.

  Callum-1623688 00:32 22 Nov 10

"Routers used in a home network most commonly allocate IP addresses that start with "192.168".

If the IP address for your network adapter starts with "169.254", then the PC has been unable to get an address from the router and Windows has defaulted to allocating the 169.254 address. This won't let you access either the router or the internet."

This has not happened. It says 192.168 on the window after running the ipconfig/all.

What should be my next step to check how it's going?

  mgmcc 08:27 22 Nov 10

From the IPCONFIG /ALL details, can you post in a reply here for the Local Area Connection:

- IP address
- Subnet Mask
- Default Gateway
- DNS Servers (usually two addresses)

  Callum-1623688 18:07 22 Nov 10

Certainly, under the Local Area Connection Heading I have this.

- IP address - 192.168.0.1(Preferred)
- Subnet Mask - 255.255.255.0
- Default Gateway - This field is completely blank
- DNS Servers (usually two addresses) -

fec0:0:0:ffff::1%2
fec0:0:0:ffff::2%2
fec0:0:0:ffff::3%2

  mgmcc 21:05 22 Nov 10

The problem is with the missing Default Gateway and DNS Server addresses. I would have expected the Router's IP address to have been 192.168.0.1 but, as the PC's adapter has been given this address, it may be that your particular router has the address 192.168.0.254 - some BT routers tend, unconventionally, to use this address.

If you plug the computer directly into the router you can check by running IPCONFIG /ALL what the Default Gateway address is and that's the router's IP address.

Once you have established the router's IP address, try allocating fixed addresses to the Local Area Connection. Open the Network Connections folder ("Start > Run", type NCPA.CPL and click OK), then right click the Local Area Connection and select Properties. Highlight the entry for TCP/IPv4 and click the Properties button. Select the option to use the following IP address and, assuming the router's address is 192.168.0.254, type in:

IP address - 192.168.0.7 (using '7' to avoid any potential conflicts)
Subnet Mask - 255.255.255.0
Default Gateway - 192.168.0.254 (the Router's IP address)
DNS Server - 192.168.0.254 (the Router's IP address)

Click OK back through the open Properties sheets.

If the router's IP address isn't 192.168.0.254 we'll need to have a rethink about it.

NOTE: To revert to automatic IP addressing, set *BOTH* IP and DNS sections back to getting their addresses automatically.

  Callum-1623688 01:17 23 Nov 10

"The problem is with the missing Default Gateway and DNS Server addresses. I would have expected the Router's IP address to have been 192.168.0.1 but, as the PC's adapter has been given this address, it may be that your particular router has the address 192.168.0.254 - some BT routers tend, unconventionally, to use this address."

It may also be that my Landlord uses the same router as me for her PC.

"If you plug the computer directly into the router you can check by running IPCONFIG /ALL what the Default Gateway address is and that's the router's IP address.

Once you have established the router's IP address, try allocating fixed addresses to the Local Area Connection. Open the Network Connections folder ("Start > Run", type NCPA.CPL and click OK), then right click the Local Area Connection and select Properties. Highlight the entry for TCP/IPv4 and click the Properties button. Select the option to use the following IP address and, assuming the router's address is 192.168.0.254, type in:

IP address - 192.168.0.7 (using '7' to avoid any potential conflicts)
Subnet Mask - 255.255.255.0
Default Gateway - 192.168.0.254 (the Router's IP address)
DNS Server - 192.168.0.254 (the Router's IP address)

Click OK back through the open Properties sheets.

If the router's IP address isn't 192.168.0.254 we'll need to have a rethink about it.

NOTE: To revert to automatic IP addressing, set *BOTH* IP and DNS sections back to getting their addresses automatically."

Right, to double check all the above should make my Homeplug work ok without affecting my Landlords wireless connection downstairs at all?

  Callum-1623688 01:28 23 Nov 10

Ok I'mma need to wait till my Lanbdlord is out to do stuff like going downstairs and direct plugging into the Router and such to find out the routers IP Adress. Unless of course Connecting with a Wireless Adapter will allow me to view the Routers IP Adress under the Ipconfig/all. Can I do that?

  Callum-1623688 21:32 23 Nov 10

The IP listed under the default gateway whe I connect wirelessly is 192.168.2.1. Is that the Routers IP or does connecting Wirelessly change things?

This thread is now locked and can not be replied to.

LG G6 review: Hands-on with LG’s bold, big-screen shot at perfection

1995-2015: How technology has changed the world in 20 years

How the painting-like animated sequences in A Monster Calls were created by Glassworks Barcelona

The 22 best Safari extensions | Best Safari plugins: Improve Apple's Safari web browser with these…