Help XP Network Settings?

  Seaco 01:27 20 Dec 04

Help I can't change Xp's Network settings, my ip address seems to have changed by itself from to I know how to change this but when I now try I get the following message (The important box is the one with the red cross) this appears when I press the settings button?

Below is a pic of my problem, if you can help THANKYOU in advance...

click here

  mgmcc 11:13 20 Dec 04

Presumably your picture is from a "client" PC using Internet Connection Sharing and the "host" hasn't been configured to (quote) "Allow other network users to control or disable the shared Internet connection"?

  Seaco 11:27 20 Dec 04

Hi mgmcc I have a desktop pc connected to a laptop on a wired network through a Netgear router, I am on broadband and I'm getting the same message on both I just need to know where to go to change the settings the message speaks of as you can probably tell I'm not to clever with networks!

I would be really gratefull for any help you or anyone can give...

  mgmcc 13:08 21 Dec 04

Seems weird but make sure that the adapters in both PCs are set to get their IP addresses automatically and that you haven't enabled Internet Connection Sharing in either PC. If you are using a "wired" router, both PCs should be getting their internet access via the "Local Area Connection" - I don't quite know what the "Internet Connection" entry is, but suspect that it relates to Internet Connection Sharing which shouldn't be running.

Right click the Local Area Connection in each PC (because that is the network adapter that should be connected to your router), select Properties and then the Advanced tab. Make sure the box is NOT ticked for "Allow other network users etc..."

I assume that you have connected both computers to the router and that you do not have any connection DIRECTLY between them?

  Seaco 13:28 21 Dec 04

No there's no direct connection between them and yes it is through a router.

I have installed service pack 2 and when I do as you say in your instructions my advanced tab only shows this: click here

Doesn't show "Allow other network users etc"

I haven't a clue whats wrong?

  mgmcc 13:50 21 Dec 04

The "ICS" option would only be available on your "Internet Connection" if there was a free network adapter to connect to a 'client' PC. If you only have the one network adapter installed, and it is the internet connection, you can't enable ICS, as you have in effect discovered.

However, it does seem as though it HAS somehow become enabled and this is giving rise to the problem. Have you ever used Internet Connection Sharing?

I have to be careful because my broadband connection is cable, not ADSL, and I know there are differences, but unless your "Internet Connection" entry is actually used to establish the connection, I cannot see its purpose.

What is actually the problem you are having? Is the network (file/printer sharing) no longer working or have you lost internet access on one/both PCs?

  Seaco 18:40 21 Dec 04

I use emule and I now have a low id I think due to my ip number changing itself from to I have had this happen on occassion and I found that the settings I put into the internet connection / properties for emule to open up the ports i.e. 4662 and 4672 delete themselves and have to be put in again, then all seems well?

The PC and the laptop are both working fine on the internet and file sharing it's just getting emule working properly again?

Thankyou again for sticking with me on this...

  Seaco 22:19 21 Dec 04

Yipee got it sorted I hadn't changed the ip addresses in the firewall settings on my Netgear router from 0.2 to 0.3 and now all seems well many thanks though "mgmcc"

PS I told you I wasn't to clever with networks didn't I!...

This thread is now locked and can not be replied to.

Apple Event as it happened | Apple October Event live blog: Apple unveils new MacBook Pro at…

1995-2015: How technology has changed the world in 20 years

Graeme Messer's exhibition aims to challenge fears and insecurities

New MacBook Pro release date, price and specs | New MacBook Pro 2016 announced: Now with Touch Bar…