Help ... Wireless Internet Sharing Error ... Vista

  Megan2682 13:22 26 Oct 08
Locked

I am trying to select "Allow other internet users to connect through this computers internet connection" on the sharing tab on my Wireless internet properties in Vista. The below message comes up:

"an error occurred while internet connection sharing was being enabled"

I have done the following to try and make it work ... so if anyone can figure this out they are an absolute GENIUS!!!!

1. Click Start, Run, type services.msc, and set the following services to automatic start up:

Application Layer Gateway Service
Network Connections
Network Location Awareness (NLA)
Plug And Play
Remote Access Auto Connection Manager
Remote Access Connection Manager
Remote Procedure Call (RPC)
Telephony

2. Changed the IP Address on my router to 192.168.0.2 instead of 192.168.0.1 (which was adviced on this issue on other forums) (also, I have a netgear router from sky)

But nothing works!!!!

Find below all the info from when a type in IPCONFIG/ALL which may help!

Thanks Guys!

Windows IP Configuration

Host Name . . . . . . . . . . . . :
Primary Dns Suffix. . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Wireless LAN adapter Wireless Network Connection:

Connection-specific DNS Suffix. :
Description . . . . . . . . . . . : Atheros AR5006EG Wireless Network Adapter

Physical Address. . . . . . . . . :
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::5565:5772:2fc1:13e5%9(Preferred)
IPv4 Address. . . . . . . . . . . : 192.168.0.3(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : 26 October 2008 12:44:54
Lease Expires . . . . . . . . . . : 27 October 2008 12:44:54
Default Gateway . . . . . . . . . : 192.168.0.2
DHCP Server . . . . . . . . . . . : 192.168.0.2
DHCPv6 IAID . . . . . . . . . . . : 251663791
DNS Servers . . . . . . . . . . . : 192.168.0.2
NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix. :
Description . . . . . . . . . . . : Realtek RTL8139/810x Family Fast Ethernet
NIC
Physical Address. . . . . . . . . :
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::b800:a1a3:cfd3:c8cd%8(Preferred)
Autoconfiguration IPv4 Address. . : 169.254.200.205(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . :
DHCPv6 IAID . . . . . . . . . . . : 218111942
DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
fec0:0:0:ffff::2%1
fec0:0:0:ffff::3%1
NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter Local Area Connection* 6:

Connection-specific DNS Suffix. :
Description . . . . . . . . . . . : isatap.{F6289ACC-F59E-4CF4-AF01-40E003555
1BE}
Physical Address. . . . . . . . . :
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::5efe:169.254.200.205%10(Preferred)

Default Gateway . . . . . . . . . :
DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
fec0:0:0:ffff::2%1
fec0:0:0:ffff::3%1
NetBIOS over Tcpip. . . . . . . . : Disabled

Tunnel adapter Local Area Connection* 7:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix. :
Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : 02-00-54-55-4E-01
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 9:

Connection-specific DNS Suffix. :
Description . . . . . . . . . . . : isatap.{C9F63FCE-2680-486A-9E20-F9127737A
21F}
Physical Address. . . . . . . . . :
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::5efe:192.168.0.3%11(Preferred)
Default Gateway . . . . . . . . . :
DNS Servers . . . . . . . . . . . : 192.168.0.2
NetBIOS over Tcpip. . . . . . . . : Disabled

  mgmcc 14:40 26 Oct 08

As you have a router which will allow all of your computers to connect independently to the internet, *YOU SHOULD NOT* be enabling "Internet Connection Sharing" in any of the computers. "ICS" is a method used to share a computer's connection to the internet when you *DON'T* have a router and you need a "host" computer to act as a router and allow "client" computers to connect through it.

Have a read through this - click here

  mgmcc 14:46 26 Oct 08

<<<<2. Changed the IP Address on my router to 192.168.0.2 instead of 192.168.0.1 (which was adviced on this issue on other forums) (also, I have a netgear router from sky)>>>>

It was the third octet (number) of your router's IP address that you would need to change to avoid a conflict with the subnet (IP address range) used by Internet connection sharing. ICS uses 192.168.0.x addresses and so does your router. You would have to change your router own address to something like 192.168.1.1 or 192.168.2.1 so that it then allocated 192.168.1.x or 192.168.2.x addresses.

Nevertheless, as above, you wouldn't normally be using ICS in conjunction with a router, unless you had a very specific requirement for doing so.

  Megan2682 14:51 26 Oct 08

I basically want to use my laptop as a wireless connection for xbox live? if there's a smarter way to do that you know of that would be fantastic!

  mgmcc 20:03 26 Oct 08

>>> I basically want to use my laptop as a
>>> wireless connection for xbox live? if there's
>>> a smarter way to do that you know of that
>>> would be fantastic!

OK, so presumably it isn't a *WIRELESS* router that you have and so you need to connect the PC by ethernet cable to your router and use its Wireless Network Adapter to connect to the Xbox? Otherwise, you would normally connect other network devices directly to the router.

The problem that you have, as per my earlier message, is that your router operates in the same IP address range as "Internet Connection Sharing" (192.168.0.x) and as ICS *MUST* use this range. You need to change the router's own IP address to a different range and it will then allocate addresses in this different range to all computers etc that are connected to it. I would suggest changing its IP address from 192.168.0.1 to 192.168.2.1

Then enable ICS on your wired ethernet connection to the router. Windows should automatically give your Wireless Network Adapter the fixed IP address 192.168.0.1 with Subnet Mask address 255.255.255.0

The Xbox should be set to get its IP address automatically by DHCP and the Vista PC should allocate it. It must be an address between 192.168.0.2 and 192.168.0.254

Your "IPCONFIG /ALL" details indicate that you have TCP/IPv6 enabled, so I'd suggest unticking the box for this protocol in the Properties of both your Local Area Connection and Wireless Network Connection. TCP/IPv6 isn't in use yet and can cause connectivity problems, as well as causing all of the "Teredo Tunneling Pseudo-Interface" nonsense and hexadecimal IP addresses to appear in IPCONFIG. However, *DO NOT* untick the TCP/IPv4 boxes.

  Megan2682 23:10 26 Oct 08

The router is wireless and in the lounge, where as the xbox is in another room, so annoyingly i can't connect to it using a cable. I want to use my laptop (which is connected to the internet wirelessly) as a wireless adaptor for xbox live by using an ethernet cable between my laptop and my console.

I have tried changing the address as you stated however i get the following message:

"DHCP Server starting or ending IP address not in LAN IP Address subnet"

I'm with sky broadband and they've provided me with a netgear router. On signing up they said i must use this router, although i'm not sure how true this is ... i also have a belkin.

I've disabled TCP/IPv6 as suggested :o)

Please Help, as i'm Super Stuck!

  Megan2682 01:01 27 Oct 08

Just fixed it!

I changed my IP Address to 192.168.1.1 but ALSO changing subnet mask to 255.255.254.0. I've then selected "Allow other internet users to connect through this computers internet connection" and bingo, it works.

Just one more question, why is selecting the above option a bad thing to do? I'm not the best with computers so didn't fully understand the comments you made about it earlier. My connection is password protected, and the only people who use the connection are trusted friends.

Thanks again for all your help

  mgmcc 08:28 27 Oct 08

>>> why is selecting the above option a bad thing to do?

It isn't a bad thing to do. I know nothing about games consoles and so have no idea which ones can connect "wirelessly" and which need a "wired" ethernet connection. I was assuming that your Xbox could have connected "wirelessly" directly with the router in the same way as the Laptop.

I won't pretend to understand why changing the Subnet Mask fixed the problem, because 255.255.255.0 is definitely the correct address, but if it works then leave it just the way it is. ;)

This thread is now locked and can not be replied to.

How to get Windows 10 for free | How to install Windows 10: There is still a way to avoid paying…

1995-2015: How technology has changed the world in 20 years

Alex Chinneck’s giant ice cube Christmas tree at Kings Cross

Apple rumours & predictions 2017: The iPhone 8, new iPads, and everything else you should expect fr7…