Help - please! Internet Connection Sharing with XP

  webber_man 12:15 17 Oct 04
Locked

Sheeeshhh! I have spent HOURS trying to figure out how to share my broadband internet connection between my desktop and laptop with nothing but more hair loss being the result!

I have gone through all the posts here click here and elswhere on PCA, looked at all the relevant websites offering advise and searched on Google. All with no joy.

Saying that, i have found a way to connect - through AnalogX Proxy Server click here , but this interferes with some programmes (MSN Messenger, Yahoo, Outlook)so i'd rather not go this route if possible.

Ok...here's the setup.

I have a desktop running XP Home and a laptop running XP Pro. I have gone into the Internet Protocol TCP/IP settings on both computers (LAN) and set the appropriate IP addresses of 192.168.0.1 (host)and 2 (client) - with the Subnet mask 225.225.225.0. I have also put those IP's into Zone Alarms Trusted Zone area. (i have tried closing down ZA and XP's firewall with zilch luck)

I initially had some troubles connecting them up at all, but after fiddling for about 4 hours i got that working. They can share files and the printer without any problem. Also the client laptop can also see the Internet Gateway connection that's on the host machine.

The computers are connect via a crossover cable/network cards.

I can connect to the internet without a problem on the host but can't get anything when opening pages on the client.

...phew! I hope i've given enough info there!

Can anyone anywhere shed any more light on this and suggest another change/tweak i might have missed? I didn't want to give up as i wanted to sort this myself but now it's absolutely driving me mad!

  JonnyTub 12:19 17 Oct 04

to see if your laptop can see the net or not, go to start type cmd and hit ok. From the command prompt type: ping click here

  jg1990 12:20 17 Oct 04

The client's IP address should be set to 'Obtain automatically'

Or so I was led to beleive.

  webber_man 12:29 17 Oct 04

Yeah - done the ping-ing business. It see's the host when i ping 192.168.0.1 but not when i ping click here ..... or any other site for that matter! All i gte is ping request could not find host....blah blah blah....works in reverse too - host/client

...also tried with the IP address on the client side too

  AndySD 12:41 17 Oct 04

Have you gone to the internet connection in Network connections and then in Properties shared the connection?

  JonnyTub 12:45 17 Oct 04

have a read through this click here there are some solutions that may help you.

  webber_man 13:36 17 Oct 04

Thanks all ....AndySD, yep done that.

JT - thanks for the link...interesting reading. Had a fiddle with IP addy's etc. and alas still now joy.

  AndySD 14:04 17 Oct 04

Is this zone alarm free edition?
If so try removing it and turning on XP's firewall (assuming its SP2)

  webber_man 14:16 17 Oct 04

AndySD - tried that too!

  AndySD 14:21 17 Oct 04

Not closing za as this doesnt work. you need to uninstall it.

Is the gateway setting on the client 192.168.o.1

  MeV1 14:40 17 Oct 04

On the host:

Right click your internet connection, choose properties then click the advanced tab and tic the box that says "allow others on this network to connect using this connection."

OK all the boxes.

right click your LAN connection and choose properties. double click the internet TCP/IP protocal and set the following options:

IP: 192.168.0.1
Subnet: 255.255.255.0

ok all the boxes.

On the guest (PC you want the internet to be shared to):

right click your LAN connection and choose properties. double click the internet TCP/IP protocal and set the following options:

IP: 192.168.0.2
Subnet: 255.255.255.0
Gateway: 192.168.0.1

then load IE and go

Tools > internet options > connections > Lan Settings (button) > Check "Automaticaly detect settings"

close and reopen IE.

This thread is now locked and can not be replied to.

How to get Windows 10 for free | How to install Windows 10: There is still a way to avoid paying…

1995-2015: How technology has changed the world in 20 years

Alex Chinneck’s giant ice cube Christmas tree at Kings Cross

Apple rumours & predictions 2017: The iPhone 8, new iPads, and everything else you should expect fr7…