Help with PCI Sound Card problem

  O-NO 23 Apr 13
Locked

Since updating my PCIe graphic card (ASUS GTX690) my PCI sound card (ASUS Xonar D1) has stopped working.

Sound card works OK in another PC.

I've tried another PCI sound card and that also fails in both PCI slots I have on my motherboard (ASUS P8Z77).

Each time I try to install that previously worked I'm prompted to fit the sound card that is already fitted.

Not sure if it's has anything to do with it or if it even should be there but I don't have PCI Bridge - 244E showing up in Device Manager under System Devices.

It's as though my PCI expansion slots aren't working

PC Spec; i7-3770K Motherboard ASUS P8Z77-V Graphic Card GTX690 Windows 7 64-bit 16GB RAM

  Fruit Bat /\0/\ 23 Apr 13

Have you tried rolling back the driver to see if the PCI card works again?

  O-NO 23 Apr 13

Hi Fruit Bat /\0/\

I couldn't find the option to roll back driver as nothing showing in Device Manager.

Advertisement

This thread is now locked and can not be replied to.

Should I upgrade to Windows 10? 8 reasons why you should upgrade to Windows 10... and 2 why you…

We are being sold the ability to spend money we don't have. And we love it

Encore creates eerie effects for Spielberg's new TV show The Whispers

How to set up Apple Music & make sure you don't get charged: Get Apple Music for free

We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message