HELP, no sound, colour all messed up, no MM funct

  DunnoWotName2Hav 22:55 20 Jan 03
Locked
  DunnoWotName2Hav 22:55 20 Jan 03

HELP guys.
I had to reinstall windows after a major crash.
Now installed windows 98, after wiping disk clean and formatting, had millenium but i thought that was erm... not good.
Anyway I didnt have millenium disks cos the Pc is second hand.
I now have the following problems,
1) No sound at all from internal speaker or external speakers.
2) Colour is only running on 16 colours. used to be 32 bit true colour.
3) Hard drive is now only 1.99GB was 9GB. I ahve not yet set up FAT 32 system. ? did i do something wrong when i formatted?
4) I have 3 devices with a yellow query mark,
a) PCI Ethernet controller
b) PCI Multimedia audio device
c) an unknown device?
5) Since the change the graphics controller has changer, it is an Intel 82810E graphics controller 4.12.01.2604 but shows as a PCI standard controller.
6) I think I may have missing driversfor
a) Intel 82801AA Bus Master IDE controller
b) Intel 82801AA USB universal host controller
c) AC'97 Driver for Intel 82801AA controller
LNE 100TX fast ethernet adaptor v.1

Im really strggling to get my system back in full working order so any help would be appreciated.

Is there a tool out there which would identify missing drivers?

Thanks guys.

Mike

  LastChip 23:54 20 Jan 03

First, how did you format your drive?

Does it have more than one partition on the drive?

How old is the computer?

  Tog 07:41 21 Jan 03

Does the BIOS detect the HDD correctly?

Run fdisk and see what it reports about your HDD.

Run scandisk in DOS and see what it reports back with.

Post back with what you find out.

Most of your driver problems probably stem from incorrect or missing motherboard drivers.

  DunnoWotName2Hav 09:54 21 Jan 03

From what I understand i have maybe made one mistake, I did not click yes to large disk support as it defaulted to no. I will go back into fdisk and check partitions etc, if i cannot correct from there i will reinstall again but this time click yes to large disk support.

does that sound like a good solution?

Thanks

mike

  DunnoWotName2Hav 09:55 21 Jan 03

I will run those tonight and then post what i find, see my response to lastchip and let me know what you think

thanks

mike

  Tog 10:23 21 Jan 03

Bonza!

  LastChip 16:47 21 Jan 03

Yes, you must accept LDS otherwise the BIOS will not recognize the hard drive disk size in it's entirety.

It looks like you are going to have to fdisk and format your drive again, and re-install Windows.

I agree with Tog. It is possible most of your other problems are related to missing motherboard drivers, and once the hard drive is sorted out, we can move further on to establishing the cause of your other problems.

In general, your motherboard drivers should be the first thing you load after the operating system, and specifically, if your MB has a VIA chip-set, the 4 in 1 drivers should be loaded BEFORE the graphics card drivers. In other words, MB drivers; 4 in 1 (if applicable) and then graphics. Once these are complete, you can look at things such as Network card, Sound card, Modem, etc. if they haven't already been recognized by Windows, or you have specific drivers you wish to update to.

  DunnoWotName2Hav 16:45 24 Jan 03

I have resolved the hard drive problem and also I have restored graphics!

But...

I still have no sound!

The driver is missing I think cos that is what was the problem with the graphics.

When I pop the back off my machine where will I find the sound card / chipset, I think it is an SiS card or chipset?

  Tog 21:15 24 Jan 03

click here

or

click here

The second one will give very detailed info about PCI devices.

  DunnoWotName2Hav 21:13 26 Jan 03

Sound is restored!

Now only smaller problems left.
1)
My system Info says that the PCI Ethernet controller is not functioning, I think the driver I need is for an LNE 100TX Fast Ethernet adaptor.
Is this important? i am not on a network.

2)
My secondary IDE controller is apparently diabled in hardware?
Lost on that one.

3)
I still have an Unknown device.
God only knows what it is but everything sems to be working OK.

4)
Do I need a specific driver(s) for the Intel 82801AA Bus Master IDE Controller / USB Host controller. (Query AC 97 Driver?)
Is this linked to 2) above?

Nearly there I think.

Mike.

This thread is now locked and can not be replied to.

Best phone camera 2016/2017: Galaxy S7 vs iPhone 7 vs Google Pixel vs HTC 10 Evo vs OnePlus 3T vs…

1995-2015: How technology has changed the world in 20 years

The Pantone Colour of the Year 2017 is Green

Super Mario Run preview | Hands-on first impressions of Super Mario Run: Mario's iPhone & iPad…