Help needed with wired NTL network sharing

  frosty1244 23:17 29 Dec 05
Locked

Can somebody please help me have been trying for days with no avail. I am trying to connect two computers with a crossover cable. It keeps on telling me that there is limited or no connectivity. Want to be able to connect both to the internet. Not sure if I should be doing something else with the settings cannot get past wizard

  mgmcc 23:52 29 Dec 05

To create a wired network for Internet access and File/Printer sharing, connect them directly with a crossover CAT5 ethernet cable. “Internet Connection Sharing” is then enabled on the actual Internet connection (the modem connection) in the “host” PC and the “client” PC will have Internet access provided the “host” is running and online.

When you enable “Internet Connection Sharing” on the Internet connection in the “host” PC, it automatically configures the Local Area Connection with the IP address 192.168.0.1 and subnet mask 255.255.255.0. The “client” PC’s Local Area Connection should be set to get its IP address automatically, which it does by DHCP from the “host”. Also, if you run the Zone Alarm firewall in your “host” PC, the Internet Zone Security level must be reduced from High to Medium or “ICS” traffic will be blocked.

To enable “Internet Connection Sharing” in Windows XP, open the Network Connections folder, right click the actual internet connection (modem connection), select Properties and then the Advanced tab. Tick the box “Allow other network users...etc”.

  frosty1244 00:16 30 Dec 05

many thanks have tried this but not working. The connection that the broadband is going in to and the one that the cable links both computers is coming up with IP address 169.254.221.157 and subnet 255.255.0.0 there is no default gateway no DNS server and No WINS Server am I doing something wrong. The zone alarm is currently switched off

  frosty1244 00:30 30 Dec 05

the IP addresses have now changed the one connected to the internet says 169.254.189.196 and the one connecting both computers says 169.254.221.157

  mgmcc 07:39 30 Dec 05

You haven't enabled "Internet Connection Sharing" on the actual modem connection to the internet in the "host" PC. If you had, it would automatically have given the network adapter which connects to the "client" PC the fixed IP address 192.168.0.1

At the same time, the "host" PC becomes a DHCP server to allocate the IP address to the "client" PC. At the moment, both of the network adapters are set to get their IP address automatically but there is no DHCP server from which to get them and so Windows is allocating default 169.254.x.x addresses which won't get you online.

<<< the one connected to the internet says 169.254.189.196 and the one connecting both computers says 169.254.221.157 >>>

If you have two network adapters installed in the "host" PC and the one that connects to the Cable Modem also has a "169.254" address, there is something wrong because it means the ISP hasn't allocated an IP address either.

  frosty1244 08:46 30 Dec 05

Sorry really stupid not very technical what else do I need to do to connect sharing. At the bottom of your message you say that there must be something wrong how can I resolve this?

  mgmcc 08:49 30 Dec 05

There are aspects of your posting that just don't sound right.

The Cable Modem should be connected to the "host" PC, either by USB or by Ethernet.

Totally separate from that connection, you should have a crossover cable running directly from one PC's network adapter to the other PC's network adapter.

This means that if you are connecting the Cable Modem by ethernet cable in the "host" PC, it would have to be fitted with two network adapters, so that the second can be used with the crossover cable for Internet Connection Sharing (which is enabled on the connection to the Cable Modem).

  frosty1244 08:57 30 Dec 05

Yes I have installed on my host computer two Belkin Desktop Network PCI card adaptors when I am not on line and trying to connect I have connected via ethernet the modem to the host pc and then the crossover cable from the host pc to the other pc. All the lights are on for the networking cable. I think I need to do something technical with the actual system?

  mgmcc 09:34 30 Dec 05

<<< I think I need to do something technical with the actual system? >>>

No, you don't. In the "host" PC, can you open a Command Prompt window (in XP go to "Start > Run", type CMD and click OK) and at the prompt, type IPCONFIG /ALL and press Enter. Post back details for both of the network adapters or, better still, can you upload a screenshot to Image Shack similar to this - click here

To upload a graphics file to Image Shack - click here

  frosty1244 10:10 30 Dec 05

Hi couldn't use the image shack as could not log on to internet?? info below exactly as shown
Windows IP
Host name: HOMEPC
Primary DNS Suffix:
Node Type: Unknown
IP Routing enabled: Yes
WINS Proxy Enabled: No

Ethernet adaptor LAC3
Connection specific DNS Suffix:
Description: Realtek TRL8139 Family PCI fast Ethernet NIC#2
Physical address 00-30-BD-B8-EE-EF
Dhcp enabled: yes
Auto configuration enabled: yes
Auto configuration IP Address 169.254.18.9.196
Subnet Mask 255.255.0.0
Default gateway

Ethernet Adaptor LAC2
Connection Specific DNS Suffix:
Description: Realtek RTL8139 Family PCI fast ethernet NIC
Physical Address 00-30-BD-72-35-11
Dhcp enabled: yes
Auto configuration enabled: yes
IP Address: 81.102.44.165
Subnet mask 255.255.255.0
Default gateway 81.102.44.254
DHCP Servers 194.168.4.100
194.168.8.100
Lease obtained 30 dec 2005
Lease expires 01 Jan 2006

  mgmcc 13:00 30 Dec 05

Strange that it refers to LAC2 and LAC3 (Local Area Connections 2 & 3) as though there were three network adapters installed, but presumably that's just the names.

The fact that you have "IP Routing Enabled: yes" indicates that Internet Connection Sharing has been set up, but the LAC3 adapter shouldn't be getting its address by DHCP which, at the moment it is trying to do but failing, hence the 169.254 address.

Try this: In the Network Connections folder, right click the LAC2 adapter (your *internet* connection), select the Advanced tab and untick the box "Allow other network users to connect through this computer's Internet connection". Reboot the PC and then reverse that procedure to re-enable Internet Connection Sharing. See if that correctly configures LAC3 with the correct fixed IP address of 192.168.0.1

This thread is now locked and can not be replied to.

How to get Windows 10 for free | How to install Windows 10: There is still a way to avoid paying…

1995-2015: How technology has changed the world in 20 years

Alex Chinneck’s giant ice cube Christmas tree at Kings Cross

Apple rumours & predictions 2017: The iPhone 8, new iPads, and everything else you should expect fr7…