Help installing modem please

  Never again 08:12 19 Jan 04

My friends’ pc (subject of a previous thread) has been formatted and is running windows 98, but I can’t seem to get the modem working.

In device manager I got the yellow exclamation marks as the pci communications device is not working properly, and therefore I need to install the correct drivers, which is where the problem gets worse.

Before formatting the system information said that the modem was a VFM56.0-PRC data fax pci modem, so I thought that I would just download the drivers from, which I did, but after installing them the device manager said that the modem was working ok but when I went to connect to the internet windows threw me the blue screen of death (fatal exception error).

No Problem I thought – just the wrong drivers messing with windows.

I took the modem out and found the following details on the modem. RH56D-PCI, R675-12, E54575.1 and 0028 Mexico. So I googled this which indicated a Conexant modem, and downloaded the drivers for these from, installed these but still the blue screen of death at the end of it all, despite device managed saying that the modem was working ok.

I then tried the driver wizard on this months cover DVD, but this did not detect the modem, which is allocated to com5, and is detected by windows.

My friend then said that the modem was a genius GM56 flex-v modem and I downloaded these drivers but still the blue screen of death when trying to connect.
He then gave me a floppy with some drivers on (v90.I.exe) but these did not work either – same result.

The modem was working before the format and reinstall, which was suggested to sort out a series of windows crashes and freezes and failed boot ups.

I have tried so many drivers now that I am being driven mad - any suggestions please !!

  AubreyS 08:19 19 Jan 04

Maybe the best and easiest thing to do is buy a new modem. I got one for a friend of mine fo £12 from Maplins.

  ventanas 08:21 19 Jan 04

I think it should probably be on Com4. Try changing the port. After making certain you have the correct model and driver.

  Never again 08:35 19 Jan 04

Thanks for getting back so soon.

A new modem might be the final answer, but it was working before. my friend only wants this pc to work for a couple of months until he buys a new one.

Windows seems to have allocated it to com5, and I have even taken it out and installed it in a different slot, but the settings seemed to be the same. Do you think that I might need to set a jumper on the motherboard to change this. Driver wizard said that com1 and com2 were available but I don't know how to allocate them manually. It did'nt see com5.

  ventanas 08:38 19 Jan 04

Coms 1 & 2 are the external ports. 3 & 4 are the usual two "virtual" ports. There will be a setting under Modems in Control Panel to change the port, but I can't remember where it is in '98. Long time since I used it.

Gotta go now, this machine need a new hdd. Back in a few hours.

  DieSse 09:17 19 Jan 04

You can't just allocate a different port to the modem yourself.When Win sets up th PCI Communications Controller, it also sets up the Com port, whchi is actually part of the modem.

The correct routine is to remove any modem installations, and any instances of the PCI Comms Controller.

Reboot the system - when Win restarts, it should then say "detected PCI Comms Controller" - at which time you point the detection routine to the (hopefully correct) driver. It should then intall the PCI Cooms Device, followed by the modem, then probably followed by a Wave Device for the modem.

It's normal for these modems to be installed on Com3, on systems that have two built-in com ports.

  Never again 09:53 19 Jan 04

I think that part of the problem that I have is that I'm not sure what modem I have or what the correct drivers are as I have conflicting information.

As said above, windows has already allocated com5 as the port.

I have removed the modem in device manager and let windows detect the modem on reboot, but this still has not got me anywhere. Could you please explain what you mean about removing any instances of the pci comms controller.

  Chegs ® 09:57 19 Jan 04

Might also be an IRQ conflict causing the BSOD's.

  Never again 10:12 19 Jan 04

Thanks Chegs but device manager is telling me that there are no conflicts.

  DieSse 11:24 19 Jan 04

You said "In device manager I got the yellow exclamation marks as the pci communications device".

My response was to make sure you removed any trace of this in the Device manager - whether marked incorrectly installed, or not.

Device manager can be fickle - and tell you there aren't any conflicts, when there are!!

To try and ensure there really are no conflicts - go into the BIOS, look for the PNP/PCI setup page. make sure PNP OS installed is set to Yes. Change Resest Configuration Data to Enabled 8it will automatically change back to Disabled after a reboot.

Then Save Settings and reboot. The BIOS will examine all your devices afresh, and reallocate resources as required - which will normally iron out any conflicts.

  davidg_richmond 11:33 19 Jan 04

Last night I had a mare trying to get a Conexant modem installed as I had no drivers. I eventually ended up at click here where they had a group of very useful generic drivers. You could try this if you believe you may have the wrong drivers.

This thread is now locked and can not be replied to.

Microsoft Surface Studio PC release date, pricing, design, features and spec: Microsoft showcases…

1995-2015: How technology has changed the world in 20 years

This amazing app turns your iPad Pro into a Cintiq

Apple Q4 2016 financial results | Apple earnings report: iPhone, iPad and Mac sales down, profits d6…