help! cant share internet

  agent 47 16:35 07 Mar 05

i have 3 pc's all on xp and all have network cards and crossover cables. on 1 pc "mine" i have 2 net cards,my pc is the main pc, and is the only one that has broadband, the other 2 share the net through my pc. i have a external "speedtouch adsl" modem.
when i first set the two pcs up, everything was fine for a couple of days, then i had trouble with the network icon in the taskbar! saying the network cable unplugged! then i had trouble with sharing the net on both pc's.
my kids havent messed with any settings, and i have clicked repair connection on the two pc's
and on my pc if i click repair connection,
it says cannot repair connection because tcp/ip is not enabled.

can anyone help!


  spikeychris 17:10 07 Mar 05

Your using X over cables, are you also using a hub? The TCP/IP issue can sometimes be fixed with click here WinSock XP Fix is free and works a like a dream.

  Chezdez 19:04 07 Mar 05

he's not using a hub, he says that he has two network cards in his main PC

did you make the cables yourself? if so, try carefully reterminating them

to check if you have TCP/IP enabled, go to network settings, right click on your LAN icon, properties

on the first page, you'll have a list of all services isntalled, TCP/IP should be there

highlight TCP/IP, click properties

what are your settings in there? (on all 3 computers please)

  spikeychris 19:30 07 Mar 05

"he's not using a hub, he says that he has two network cards in his main PC"

Yup you're right. Lazy reading...again!

  FelixTCat 19:41 07 Mar 05


Go here: click here;en-us;316276 and follow the instructions carefully. I have not come across this application using 2 network ports and crossover cables on 1 computer - I had thought that you could only use 1.

  spikeychris 20:22 07 Mar 05

Thats click here


  agent 47 20:52 07 Mar 05

i tried the winsock xp fix, it fixed then rebooted, and it caused an error, my pc would not boot, it took me to the password login screen, i entered my password, then a couple of seconds and it shut down my pc! it took me to the "blue background" error screen.
anyway ive sorted that prob!
now back to my network prob.

i will refer to my pc as "pc1"
and the two that share mine "pc2" and "pc3"

i have bought the cables!

on the general tab the selected option is "obtain an ip address auto"
"obtain dns server address auto"
on the alternate config,
"auto private ip address"

same as above "pc2"

on my pc, pc2 shows the same"pc2"
on my pc, pc3 shows
"use the following ip address"
"use the following dns server address"

on my pc "speedtouch connection" "properties"
"networking" "tcp/ip" shows
"obtain ip address auto"
"obtain dns server address auto"
i hope this info helps


  Chezdez 21:12 07 Mar 05

ok, now run the network setup wizard, should do it no probs

*fingers crossed*

  agent 47 10:15 08 Mar 05

i have run the network setup wizard, on all three
pc's. but still same problem, cant share internet
on other two pc's!
any other suggestions!


  TomJerry 00:13 10 Mar 05

have you enable "Internet Connection Sharing" in the main PC

still not work? Then just spend £28 to get a modem router will put you out of all trouble. Of course, you need a few more pounds to get Cat5e cables as well

Ebuyer 4 Port SPI Firewall ADSL Modem Router £28.19 click here

  FelixTCat 00:33 10 Mar 05

What are the IP addresses of all three pcs?

You can get these by opening a dos window (Start - Run - cmd) and typing ipconfig [Enter]. On pc1, type ipconfig /all [Enter]

To copy them to your answer, right-click on the blue title bar and click Edit - Mark. Highlight the bit you want. Right-click again on the title bar and click Edit - Copy. Then paste into the response box.

This thread is now locked and can not be replied to.

Surface Studio vs iMac 5K comparison review: Apple and Microsoft all-in-one PCs battle it out

1995-2015: How technology has changed the world in 20 years

Social media image sizes, specs and aspect ratios: the ultimate guide

New MacBook Pro release date, price and specs | New MacBook Pro 2016 announced: Now with Touch Bar…