Help - ATI radeon 9800 xt frying!

  fredzepp 14:32 21 Nov 06
Locked

Hi everyone,

I am running an ATI radeon 9800 xt on a MESH Matrix PC - it used to perform fine but recently the tempeature of the video card cpu has gone through the roof - cuurently running at 100 deg c plus in 2D mode. I think this is making it crash in 3D games!

I have tried updating to latest drivers and replacing the thermal compound on the CPU but to no avail.

Can anyone suggest any possible causes/remedies or am I looking at a new 3D graphics card?

Thanks for any help

  Hertz Van Rentyl 15:55 21 Nov 06

Has the fan stopped working.

  fredzepp 15:58 21 Nov 06

No, the fan is still operating ok.

  De Marcus™ 16:02 21 Nov 06

Is it overclocked?

  fredzepp 16:11 21 Nov 06

Thanks for your reply. No, not overclocked - actually, I put the new thermal compound on this morning. First time I used the PC, the temp went sky high to 109 degrees. It now seems to be stabilising at between 70-80 so thats an improvement but still v.high, no?

  gudgulf 18:59 21 Nov 06

Could anything be obstructing the airflow throgh the case.....vents at front lower/sides of case clogged with fluff or the cvables inside the case blockinf smooth airflow?

Are the psu fan and any case fans working properly?

Try running temporarily with the case side off and see if this brings the graphics cards temperature down.

  fredzepp 22:06 21 Nov 06

gudgulf, thanks for your suggestions. I have removed an Osprey video card which was obstructing airflow - this has helped a bit. All fans are working ok. The case side is off and the temperature has at least stabilised now & no longer going into the stratosphere!

I blew a shedload of dust out of the cooling vents as well when I had the ATI card removed. All these things have helped reduce the temp but it is still running hotter than it should be. 74 degrees average at the moment in 2D mode - does anyone know if this is normal(?), most people in discussioin forums seem to report temps of around 40-50 degrees.

Thanks for your help.

  citadel 22:32 21 Nov 06

I would get a new card as they have moved on a lot since 9800 days.

  gudgulf 09:26 22 Nov 06

You don't say how you are measuring the temperature.

I assume it's via the ATI control panel.

Try ATItool click here

Whilst it is primarily an overclocking tool it has good monitoring facilities and fan speed control.

If you use this and set the fan to run at 100% for all temperatures.....then check the running temperature.

It's possible your fan is slowing down with age...not failing, but not running a fast as it should.

You could try fitting one of these click here or as citadel suggests you could use your problem as a reason to upgrade the card.

  fredzepp 14:17 22 Nov 06

Cheers gudgulf, some great advice here - I will try the ATItool software first and maybe later the cooling hardware.
Yes, I am using the latest Catalyst control panel and monitering via the Overdrive facility. Thanks v.much for your help.

  fredzepp 15:55 22 Nov 06

Update:
Installed the ATItool software and have now discovered the problem! It's definitely the cards fan which is slowing down intermittently, when the fan slows temp goes sky high again. Actually, I had previously noticed a grinding noise coming from the case and assumed it was the hard drive - actually it was the Radeon's fan. I assume the fan bearings must be on the way out?

Well, it's working ok now - ATItool shows cpu at 70 and ambient temp of 48, best I've achieved this week. Fingers crossed it will stay that way until I can get a new cooling unit...

This thread is now locked and can not be replied to.

Surface Pro (2017) vs Surface Pro 4

20 groundbreaking 3D animation technologies coming to Siggraph 2017

iPad Pro 12.9 vs Surface Pro 5