help again rundll32 in win 98

  rubyred1 10:01 24 Nov 04
Locked

I thought I'd fixed this but the problem has come back again. I used sfc to extract the file from my Win 98 disk and it worked fine, but now it's happened again. I get 'cannot find the file c\windows\rundll.exe or one of it's components, make mure pathways etc are available', and so I can't use anything on my control panel or adjust my clock etc. I'm not sure what to do next. Thanks

  JIM 10:35 24 Nov 04

go to find files and type in rundll32.exe come back and let us know how many are listed on your system.

If more than 1 listed make a note of where they are on your system.

You should have 1 in the c:\windows folder.

There is or should be 1 rundll.exe also on system.

  rubyred1 10:47 24 Nov 04

Done that Jim. There is one in c\windows and also one in c\windows\helpdesk\sfc. I did have another one when I checked yesterday but that seems to have disappeared!!

  rubyred1 10:49 24 Nov 04

Sorry typed in wrong thing. Done it again and it's saying there are no items

  JIM 11:03 24 Nov 04

There must be a conflict somewhere and your been running your windows for some time now.Can you pinpoint what started it of in the first instance.A change to your setup you made,or did you notice problem after installing some software etc.Anything else that may help.

What did you do today to notice the problem if anything.

Jim.

  JIM 11:07 24 Nov 04

we have crossed before i saw your last post at10-49.

your saying now that there is nothing in the find

no rundll32.exe or rundll.exe ? if thats the case for now,

Run the sfc again for a start.

  rubyred1 16:16 25 Nov 04

Hi again Jim, sorry for delay in replying, had to go to work. The only thing I can remember doing is taking off my screensaver as scandisk was running and the screensaver interups it. So I set it to (none). It wasn't until a few days later that I tried to put screensaver back on that I got the rundll32 prob. I've managed now to put it back on just now by runnning sfc, and I've checked in 'my computer' and theres a rundll.exe and a rundll32.exe. Only problem is the rundll32 disappears every time I shut down or restart, so I have to keep repeating sfc. The only other thing I find is that when I shut down I get an error message that 'kem' (whatever that is) has caused an error. Could that be something to do with it? This has only started since Monday! Cheers

  JIM 16:39 25 Nov 04

Kernel error?

Does it show followup message or any-thing else.

Can you enlighten me ;)when you say(Only problem is the rundll32 disappears every time I shut down or restart)

When you say (when I shut down) shutting down after doing what,anything in particular.eg,using internet exploreror some other program?

Stick with it,typical win98 :)

  flecc 17:26 25 Nov 04

rundll32 supplies Desktop Properties amongst other things in Win98, so the problem almost certainly occurred at the time you were changing that screensaver.

Try changing rundll32 manually. Just delete the one in the Windows folder (that's the only one in the system that matters), then go to the cabs in the Win98 folder on your Windows 98 CD and double click this cab, Win98_46.cab. When it shows it's contents, drag out a copy of rundll32.exe, then put it in the Windows folder.

  JIM 17:39 25 Nov 04

have an ace on your thread with good advice ;)

  rubyred1 20:46 25 Nov 04

Seems to happen when I shut down after using any program. Although, when I started up just now, I tried it and it worked fine!!! Whats going on?? I hope it's going to be ok now. If not I'll try your advice guys. You've been a great help thanks very much. There may be another installment......!!! :) xx

This thread is now locked and can not be replied to.

Surface Pro 5 News - release date, UK price, features, specs

Gear VR vs. Daydream: Which delivers the best VR experience?

Best Mac antivirus 2017