Heatsink tightness

  chub_tor 14:36 24 Apr 08
Locked

I am putting together a new Athlon 64 X2 system on an ECSNForce6M-A Motherboard and using a Thermaltake RX K8 Silent Boost Heatsink. All parts were purchased in the USA while I was on vacation. This is my first build for some time and in the past I have always found that the heatsink lever is quite a hard push down and that the heatsink is really tight on the processor. With these new parts the heatsink fits tight but yet I can still slide the heatsink over the processor on the thermal grease after the lever is pushed down. Before I switch on I would like some opinions as to whether this sounds normal or not.

  Ditch999 14:49 24 Apr 08

Maybe I'm reading it wrong but that HS doesnt appear to support AM2 CPUs.

  Ditch999 14:50 24 Apr 08

Post the exact CPU specs please.

  Ditch999 15:01 24 Apr 08

I wouldn't advise switching it on until you are sure it is a correct HSF for your CPU.

  chub_tor 15:57 24 Apr 08

CPU is OEM:
AMD A64 X2 5600+ Ty AM2
Athlon 64 X2 Dual-Core
ADA5600IAA6CZ

Heatsink is:Thermaltake RX Series P/N CL-P0296
Clearly says on packagingApplication for AMD Athlon 64 X2. click here

Motherboard is click here

  Ditch999 15:59 24 Apr 08

Yes but there are different sockets for X2. Your CPU is AM2 and I belive the X2 referred to on the HSF is 939.

  chub_tor 16:13 24 Apr 08

I have the packaging and the Installation leaflet in front of me. Both say "Application for AMD Athlon 64 X2, Athlon 64 FX, Athlon 64, Sempron (Socket AM2/939/754)"

The heatsink fits over the Motherboard clips, it locks down but it just seems looser to me than in my past experience.

  Ditch999 16:18 24 Apr 08

Then I guess its ok, but I would be keeping a close eye on your temperatures (which you should do anyway when installing a CPU) The BIOS temp is the quickest way to see how hot it gets and quickest to shut it off if necessary.

  Ditch999 16:20 24 Apr 08

That HSF has the spring clip running through the middle of it. Sometimes the tension in these can be less than you would expect.

  chub_tor 21:32 01 May 08

I am marking this as resolved, the machine has been running for several days now and apart from one glitch it has been running well with the BIOS giving the CPU temperature as 40 degC.

This thread is now locked and can not be replied to.

The Legend of Zelda Breath of the Wild review: Five hours with Zelda on the Nintendo Switch

1995-2015: How technology has changed the world in 20 years

How the painting-like animated sequences in A Monster Calls were created by Glassworks Barcelona

The 22 best Safari extensions | Best Safari plugins: Improve Apple's Safari web browser with these…