Headset randomly disconnects and reconnects

  umagaar 16:45 19 Jul 14
Locked

I've recently bought an Astro A50 wireless headset, and everything was working fine until a couple of weeks ago. The problem is that my headset randomly disconnects and then after a few seconds reconnects again, as if it had been ejected from the USB hub. I've tried soooo many solutions by now, that I can't them all, but here are some of them: - I've tried every single USB port in my computer, and it's the same in everyone. No other USB device has any trouble, not even other wireless headsets. - I've tried re-installing the drivers for all my USB root hubs. - I've tried changing the battery settings so it won't hibernate. - I've tried other USB cables - I tried it on another computer, where I could not seem to recreate the error. - I have been in contact with the Astro company, and in that discussion they concluded that the headset was faulty. So I returned it and got a new one. But guess what.. the problem persists.

Ergo something is wrong with my computer, and I cannot for the life of me figure it out! I would be forever grateful if someone could enlighten me on the cause of this problem.

My OS is Windows 7 home premium 64-bit

  spuds 17:01 19 Jul 14

"I have been in contact with the Astro company, and in that discussion they concluded that the headset was faulty. So I returned it and got a new one. But guess what.. the problem persists."

Have you contacted Astro for further advice, and reported the second failure?.

The other alternative is to perhaps do a Google search, and see if someone else is having similar problems?.

  umagaar 17:07 19 Jul 14

Yes I've contacted them again, waiting for a reply. And I've searched google dry for answers. I cannot find anyone with the same problem

  rdave13 17:18 19 Jul 14

As they are wireless it makes me think it could be interference of some sort. Have you moved a router or an electrical appliance lately?

  umagaar 17:23 19 Jul 14

No I have not moved any electrical appliances that I can think of. But I do have my wireless receiver for my wireless network right next to the receiver for the headset. But they have been like that for months. But I will move the wireless internet receiver and see if it helps.

  umagaar 12:37 21 Jul 14

Moving the wireless receiver did not help either...

This thread is now locked and can not be replied to.

Surface Pro 5 News - release date, UK price, features, specs

Animator Emanuele Kabu’s psychedelic video is a stunning tribute to Lisbon city

Best Mac antivirus 2017