HDD is showing as "Primary Slave" in BIOS

  Ben Avery 11:31 29 Dec 03


I recently removed my 40GB Seagate drive and replaced it with a 60GB version (the 40GB one has been placed into an external USB housing for proptability between desktop and laptop computers).

For some uncanny reason, when I entered the BIOS to auto detect the new hard drive, the drive only detects under "Primary Slave" drive, despite the jumpers being set to Master and the drive being plugegd into the end (black) connecotr on the secone IDE cable.

I believe the IDE-0 cable is configured as follows:

IDE-0: Master=CD-RW; Slave=DVD-ROM

The drive detects in the BIOS fine but only as Primary Slave, not "Primary Master" as I thought it would.

Does this actually make any difference?

I began to install the O/S yesterday and it seemed to work ok as "Primary Slave", until I had to prematurely abandon and head off out! - Will redo it tonight at some point hopefully or during the week sometime.

Please advise.



  Jester2K 11:33 29 Dec 03

Double check the jumpers and cable position...

  Ben Avery 11:37 29 Dec 03

G'day mate,

good to see you are firing on all cylinders as usual with your rapid replies!

I checked the jumpers before I even thought about posting, seemed the most obvious error. I will try to take some digital snaps of the drive and jumpers if I get a chance but I'm 100% certain that they were correctly configured - that's why it confused me so much!


  LeadingMNMs 11:42 29 Dec 03

Should the HDD not be on the primary IDE instead of the secondary ?

  Jester2K 11:47 29 Dec 03

LeadingMNMs - doesn't matter...

Ben Avery - morning! Just checking... This might be really stupid and i can't see how it could happen but is the cable in the right way round? ie you don't have the Master end plugged in the mobo and the HDD connected to the Mobo end??

  Ben Avery 11:56 29 Dec 03


Classy thinking! I'll spare you the "what do you take me for" speel! ;o) and stick to "no unfortunately that is an impossibility, as I haven't removed it from the MoBo, simply unplugged the cable and replugged it into the new drive"!

Cheers though, I'll have another peek when I get home and check it all over again. The only thing I can thing of, is that somehow, the diagram sicker has been stuck on upside down and so the jumpers should be at the other end?

We shall see!


  Ben Avery 11:58 29 Dec 03

I don't think that's possible as, if the jumpers were at the other end, I believe that limits the HDD size in some way, can't remember the exact amount but it had a 3 in it! :o)

Maybe limits to 3GB or 3xGB in size? Who knows!

Still, I'll check anyway.


  Jester2K 12:00 29 Dec 03

Ah "diagram sicker has been stuck on upside down and so the jumpers should be at the other end?"

Now i fell into this trap once (OK, more than once) of looking at the sticker and then rotating the drive round instead of lining it up with the sticker! (Do you see what i mean?) Sometimes the sticker indicates an extra row with one pin that you should use for referencing with the sticker to make sure you have the right pins connected!!

Does that make sense??

  DieSse 12:01 29 Dec 03

"Maybe limits to 3GB or 3xGB in size? Who knows!"


  Ben Avery 12:05 29 Dec 03

Yup that's what I did (although, admittedly I can't remember using the extra row as a reference) yet the drive shows in the BIOS as 57GB or there abouts so surely this cannot be the problem as that constitutes far more than 32GB (thank you DieSse!) which would be the other setting.

It also detected this amount (57GB-ish) when I ran the Win2K / WinXP boot sequence to format it.


  Jester2K 12:23 29 Dec 03

I still think its accidentally set to Slave. Let us know...

This thread is now locked and can not be replied to.

Microsoft Surface PC release date, price and specs: All-in-one Surface PC to directly rival iMac

1995-2015: How technology has changed the world in 20 years

Best Photoshop video tutorials: 8 video tutorial websites for Photoshop

Apple's event invitations decoded: A look back at 16 of Apple's most cryptic invites | Clues in…