Having problems with this site

It doesn't matter which forum I try to access, it takes 2-3 minutes to get anything back once I have clicked on a question.

I got a friend to try from home and they are getting exactly the same thing. We are both on different networks, using different ISP's.

When will this be fixed?

Not sure if this post will get through.

  Magik ®© 14:49 27 Aug 04

thats the answer, rub all the replies out...

:-)

  mco 14:51 27 Aug 04

know what you mean - me too - but it's obviously them not us. I like to think it's because that the forum is so hugely popular throughout the world that so many millions are trying to access it!

  johnnyrocker 15:17 27 Aug 04

same here i have tried 3 times to post a question without success.

johnny.

  end 18:16 27 Aug 04

there are lots of threads running with a similar theme; F.E. has posted that he IS aware of the issues and is trying to sort them; I think it has been "down" several times today ; it is a hugely successful site and very widely used so....;)

maybe people need to look AT the other threads to see what is "going on" before posting yet another thread:(

and if you cannot get on the forum...try again later..."works for me"....

  andrew-194461 20:39 30 Aug 04

I am new to it and have found that trying again later helps but more often just wait a moment longer than your patience lasts and it comes up. Sometimes it's quick and others not - heavy use of the site may be the reason - keep going I have had help on the two things i needed

This thread is now locked and can not be replied to.

How to get Windows 10 for free | How to install Windows 10: There is still a way to avoid paying…

1995-2015: How technology has changed the world in 20 years

Alex Chinneck’s giant ice cube Christmas tree at Kings Cross

Apple rumours & predictions 2017: The iPhone 8, new iPads, and everything else you should expect fr7…