Has my computer got a virus?

  IzzyBrydonator 22:13 09 Jan 15
Locked

I recently got a new computer, and I've had it for around 2 weeks now. However yesterday I tried opening a page on Chrome and a pop-up came up saying I needed to upgrade my flashplayer to get on to pages. It seemed to look real enough so I said install. But after that I got lots of random applications installed, and my browser became slow and changed my home page to omiga plus search, which was filled with ads. Eventually I managed to erase all these ads and programs by using AVG and YAC, and after that my computer was running fine again. Until earlier today, suddenly I can't load any pages on any browsers, as it says 'unable to connect to proxy server', also on Steam I can't view any pages and some of the avatars and pictures are missing. I've tried going in to internet settings then LAN settings and unticking the box that says proxy, but every time it resets itself. I was wandering if this was a virus, and what I could do to fix it, or if there was some problem with my computer. Sorry about my lack of understanding in computers aswell. Thanks

  Fruit Bat /\0/\ 22:21 09 Jan 15

Do a system restore to 2 days ago

To restore your PC to an earlier point in time

Swipe in from the right edge of the screen, then tap Search. (If you're using a mouse, point to the top-right corner of the screen, move the mouse pointer down, then click Search.)

Enter Control Panel in the search box, then tap or click Control Panel.

Enter Recovery in the Control Panel search box, then tap or click Recovery.

Tap or click Open System Restore, then follow the instructions.

  IzzyBrydonator 11:23 10 Jan 15

I've given an AVG check and a Yet another Cleaner check but nothings come up. Also, I've checked my google chrome extensions and there is no flash-player 11. I think I have removed these viruses with my computer scans, but now I am still unable to open any pages on any browser because of the proxy server message.

  Fruit Bat /\0/\ 14:29 10 Jan 15

Yes AVg probably delete (or moved to chest) the virus infected files hence part of windows no longer working correctly.

The virus has reset your browser settings to work through a proxy they need setting back again.

A system restore to 2 days ago (before your problem started) will put the correct windows files back and put your browser settings back to normal.

AVG is OK (there are better antivirus programs) back it up with Malwarebytes free (just do not download anything from Cnet with out using custom install and unticking all the addon programs that come packaged with what you wanted.)

ADWcleaner is an excellant free program for check against addons and unwanted toolbars etc. that get put on by viruses.

This thread is now locked and can not be replied to.

Best phone camera 2016/2017: Galaxy S7 vs iPhone 7 vs Google Pixel vs HTC 10 Evo vs OnePlus 3T vs…

1995-2015: How technology has changed the world in 20 years

The Pantone Colour of the Year 2017 is Green

Super Mario Run preview | Hands-on first impressions of Super Mario Run: Mario's iPhone & iPad…